[ST Edge] DSC Security System / Envisalink Driver (2021)

Can you post a screenshot of your device settings? It doesn’t look like it has successfully communicated with your EVL4. If you have the SmartThings CLI, getting some driver logs would be helpful as well.

My system has been working great since last year you helped me out. However, after a power loss yesterday, my DSC Panel in Smartthings App stays “Disarming” and no sensor is reporting status. Checked EyezOn portal, it says " *System Trouble: Failure to communicate". What do you think is the problem? TIA!

Try rebooting your hub, that should fix it.

Rebooted a couple of times still no go☹️

I re-read your post, if you have an issue connecting to the EVL itself, it sounds like a network issue, maybe a bad connector? Try replacing the cable to the EVL.

Thank you for your kind help! I can connect to EVL4: it says On-Line but won’t report the sensor states.

At this point I would power cycle the alarm panel entirely.

Unplug the brick from the wall and disconnect your backup battery. Leave it that way for 30 seconds then plug the battery back in and plug the power brick back to the wall.

I’ve had that specific procedure work for me with those odd communication issues.

1 Like

Thank you! I did the reset as you recommended and the “Failure to communicate” error is gone now. It’s strange that the EyezOn portal shows every activities, it just does not report to ST. Do I need to do something with the ST driver for my DSC system?

1 Like

Problem solved! I found there are two versions of Envisalink driver. I switched back to 2.1 and reboot the ST hub and it is working immediately. I believe the reboot procedure you recommended solved the core problem.

Thanks again for your great help!

Yeah, you’ll need to plan to uninstall the v2.1 drivers as that has been halted for development and replaced with the 3.1 driver.

You’ll have to delete the v2.1 driver and all the associated devices it created and then install the v3.1 driver and all it to reimport all the devices. Then update any routines. I did this and I believe it took me all of about 20 minutes.

Thank you for the kind help! Do you have more detailed instructions to do the update from v2.1 to 3.1? I don’t want to mess it up since this diver for my DSC system is the most used part of my smart home.

I upgraded mine from 2.1 to 3.1 back on post 401 or 492 I think.

It really is a simple as deleting the driver and all the associated remnant devices. Fortunately the new versions of Smartthings doesn’t delete a routine when you delete an associated device, it just marks it with an error, then once you reinstall the driver, get it configured and get all of your sensors back in place, you simply edit the routines and add the respective device back in.

All in all I took me about 20 minutes and I have 13 zones - 11 door/window and 2 motion that I use in routines.

I also don’t have the STHM sync enabled because it is simply too unreliable so I’m using virtual devices with routines to keep the driver device synced with STHM.

Will do. Really appreciate your help! Have a great weekend…

Just wanted to say I’m so grateful for the community stepping in to help answer questions on here. Unfortunately I’ve been somewhat absent and haven’t been as responsive as I’d like to.

@efan2000 - if you ever get to a point of being able to recreate problems like that at-will, let me know, since that would certainly help me understand better what causes the hang-ups and what, if anything, I can do in the driver to better recover from them.

1 Like

Hi, I’ve been away from this forum for a while. Is it possible to use panel states to trigger routines?

I want to run my Out Late routine at sunset only if the panel is Armed Away.

Yes


1 Like

@TAustin,

I have actually been able to recreate the problem now on a semi regular basis.

Been having power issues and as a result have been running on generator backup on occasions.

My alarm backup battery is apparently weak, so if it is too long an outage, the alarm completely looses power (bizarrely the alarm is wired to my central air circuit breakers and thus isn’t powered by my generator) . When it comes back, it doesn’t sync back up with smartthings. Rebooting the smartthing hub gets everything working again.

Note, the hub and all wireless equipment are on a large battery backup, so they don’t cycle with the power fluctuations.

I will be happy to help troubleshoot however I can, but you might have to point me to how to do basic things, like loggind and whatnot.