[ST Edge] Driver for Ring Keypad 2nd Gen

I had the same problem. The answer is upthread: You need to create automations using the button presses as triggers. Once I started fiddling with it, I’ve got it working to disarm with an entry countdown, Arm Away with exit countdown, and Arm Home for when my husband leaves in the morning and I’m still asleep.

I enter the correct PIN and nothing happens

BTW, this was the biggest clue for me. The keypad let me know when I did something wrong, so I knew it was set up correctly, at least.

1 Like

I found the answer I mentioned. Hope this points you in the right direction:

You need to create the automation for that, like “IF the alarm is disarmed AND the Arm button was pressed THEN make the device count down, wait N seconds and then arm home/away”. The time for the keypad count-down is also configured by the driver so you need to align it with the automation.


Thank you for the reply! So I’ve noticed something now that I’ve been trying to setup automations like that with the keypad. Every time I configure an “If, Then” routine with the keypad, I receive a pop up message in the iOS ST app stating “Network Error” with options to “Cancel” or “Retry”. It doesn’t matter how many times you retry, same message.

I’ve only been able to create one automation with the keypad thus far and that was one where I was playing around with a ZEN32 scene controller and had "single press button 1 to disarm the keypad and also ST Home Monitor and then send a notification.

I’ll attach a screenshot with the “network error” message which appears when I try to create any automation involving the keypad in the “IF” argument.

1 Like

I ran into that too. I’m not entirely positive this is correct but it seems that if you have the Keypad do more than one thing at a time in an automation, you get that error. I tested this by recreating your screenshot without the keypad action in Then and it saved fine; added that back and got the error.

To get around this, I split my automations into parts. My “Arm Away” routine just does the exit delay in the first part. When that finishes, it notifies that the armAwayButton was pushed, and the next part looks for that and also if the door is locked, both as preconditions. Then it calls via a virtual switch my pre-existing “All Away” routine, which I also can use with geofencing or Alexa triggers. There’s some redundancy this way (the “All Away” also locks the door, and sets the Arm Away status on the keypad and STHM) but so far it doesn’t seem to have been a problem.

Spaniard here with a newly acquired Ring. The current Spanish in the list is Spanish (Latin America) and LANG_13 it’s Spanish (Spain)

Would you mind sending me a screenshot of your automation setup? I must be missing something. I finally figured out how to get all modes armed or disarmed with the PIN which is great, but I’d love to have an exit delay and also an entry delay. I have STHM setup for a 1 min delay in the main monitor settings, but I really miss that countdown sound from the Ring keypad. It would be awesome to have that back if possible.

Other than that, I have Actiontiles running on a Kindle Fire HD8+ with virtual switches for the arm/disarm modes and it works great! Everything is reflected realtime on the keypad and vice versa on the tablet.

If I could just get my Away & Armed countdown sound for exit and the Entry delay countdown sound for disarmed I’d be golden!


Here’s a screenshot of my tablet running Actiontiles. Works pretty damn well!

1 Like

any progress on this over the last week? managing codes with this keypad would be great. not in any rush with it, just curious how things are going. right now I haven’t even moved it into a place for the family to use regularly.

My most complicated routine is “Brief Exit” which is an Armed Home with the added complication of automatically rearming after 1 minute. My husband used to leave for work very early, long before I had to wake up, and would sometimes forget to reset the alarm so I automated it. These are screenshots of that after I rebuilt it this week to use this driver. Hope they help.

It uses 2 virtual devices; the first is a momentary button that can take input from several sources to make it easy for my husband when he’s rushing out the door. The vButton’s only purpose is to trigger a virtual switch.

One thing that threw me is that the “exitDelay” function doesn’t do anything, other than count down. You have to trigger the change of alarm state separately. The same is true for the entry delay.


Thank you! I’m going to give that a go today. My Konnected panel just arrived today so I’m about to do a deep Saturday dive into alarm world.

Thanks for your work on this hmorsti

Not sure if anyone else has seen this but I’m having some issues. I believe i have installed the driver correctly, the keypad paired easily and is appearing in smart-things. I’ve had a go at setting up routines but I just cant get it to interact with smartthings. Clicking on the keypad device will briefly show an error message, “The device hasn’t updated all of its status information yet. check again later”. And all of the fields appear blank. Not sure if im missing something obvious.

Not sure how you got there but this happened to me after the keypad went non responsive (not happened since), I removed it like a Zigbee device and then when re-added it came back like yours, I then ran through how to ‘exclude’ the device (as its Z-Wave) and after excluding and then re-adding it was fine and has been ever since.

Thanks SlySi. I figured out it was my mistake on the driver upload. I had managed to duplicate content of the separate init.lua files so the driver was only half working. Definitely connected now just struggling to get some advanced automations working :exploding_head:

I was way way too optimistic about my ability to fumble through this. 0 progress.

1 Like

To anoyone having the problem with setting up the routines for arming/disarming. In THEN section you cannot use Ring Keypad security mode capability. You need to use SmartThings Home Monitor security mode. The security mode of the keypad should not be used in THEN automations at all because SmartThings uses all devices with the security mode capabilities and sets the proper status automatically without any automation (magic :slight_smile:).

@TripleA I see in your screenshoot that you are trying to use keypad security mode in THEN section. Please use it as you can see in @epukane answer:

BTW in my opinion the network error is not the best error message which SmartThings could show to indicate that error :slight_smile:

If you are interested, for the arm away with delay I am using the rule:

name: Arm away
  - if:
          string: pushed
              - xxxxxxx-xxxxxxx-xxxxxxx-xxxxx
            component: armAwayButton
            capability: button
            attribute: button
        - command:
              - xxxxxxxx-xxxxxx-xxxx-xxx
              - component: exitDelay
                capability: tone
                command: beep
        - sleep:
                integer: 30
              unit: Second
        - location:
            locationId: xxxxx-xxxxx-xx-xxxxx
              armState: ArmedAway
  actions: Serial

has anyone with the know-how looked into getting this hooked into SLGA lately?

Thank you for the sample routines. :smile: I am trying to access the “exitDelay” function to visually show the set 60 second delay which I setup in a separate routine. The only conditions I have available when I select the Ring Keypad is ‘Alarm type’ & ‘Security mode’. How did you select the “exitDelay” option?

In reference to having the ability to use the 'ExitDelay - Find sensor" countdown feature…

I am trying to access the “exitDelay” function to visually show the set 60 second countdown on the Ring Alarm Keypad, (the red timer progress bar). It appears that epukane was somehow able to include the Ring Kepad’s ‘exitDelay - Find sensor’ element in her ST app “Then” actions:

The only actions which I have available when I attempt to create a ST routine using the exitDelay feature for the keypad is ‘Alarm type’ & ‘Security mode’. (See screenshot)

How do I gain access to select and use the “exitDelay” option within a SmartThings routine?

Loving the work you’ve done with this, thank you.

Question about the delay code rule you’ve shared (and apologies if it’s stupid question, not worked with Edge drivers before). Where have you put this code?

I assume it’s in the src part of the driver, but I can’t see where I’d add it in?

As long as you have the driver installed, you shouldn’t require any other code. You also no longer have to install the driver, @hmorsti has published it so you can subscribe to his channel, the invitation is above, subscribing has the added benefit that it will auto update when changes are made although @hmorsti is currently only providing fixes and/or fingerprints. If you are going to subscribe, make sure you delete the driver you installed manually first.

Once the driver is up and running, and you have the keypad paired (instructions above), make yourself familiar with the ‘settings’ first and then using the information posted above you should get an idea how this can work for you. You then create your routines for Arm Away, Arm Stay, Disarmed, etc… directly through the device itself. My suggestion is to keep it simple and get disarmed working first as this is usually the easiest, then tackle the home and away.

My other suggestion is once you have everything working, make note of your keypad settings, the routines you use and the other devices in them. Im not sure how it happened but the kaypad jammed on me once and I had to remove and re-add it which meant it needed to be setup again, something I found painful.

Good luck!

1 Like