[ST Edge] Driver for Ring Keypad 2nd Gen

@hmorsti is it possible to add now exposed “extra data” to this driver. This would show codeId, codeName, etc. This would allow to be used as condition, and to recreate LUM, through routines

This the link to SharpTools discussion about new exposed data

Hi is your driver updated for the US version yet?

1 Like

Hi, I have just updated it. You either need to wait for 12 hours or reinstall the driver. Please verify if it works for you.

Hi @milandjurovic71
this driver does not use the lock events. As I said before, everyone’s needs are different, some would like to see the arm/disarm as buttons, maybe some would like to see it as a lock. I think it should be possible to add the lock capability and also additional event properties but I don’t have plans to do that. Feel free to fork my github repository and adjust the code to your needs :wink:

1 Like

@hmorsti I have sent you DM

Hi, thanks. I actually made the modification to the fingerprint and init file myself yesterday and can confirm it is working with the us version. Thanks for your speedy response!

1 Like

Got it!

Good to hear. I also updated the source code on the repo to support the US version.

1 Like

Hello, I followed the tutorial to manually install the channel and driver and it wasn’t until after I installed it that I noticed the 0x0301 needed to be changed in the init and fingerprint files. I changed those, but I don’t believe that impacted anything.

This is my first time working with Edge drivers so I continued reading and found the invitation to your channel for NA users.

I followed the prompts on your channel invitation and successfully installed the driver (again?).

That being said, I have 2 questions:

  1. Did the install via the channel invite write the correct 0x0301 value to the init and fingerprint files or do I have 2 versions of the same driver installed now?

  2. I’ve been using Ring for years, so I’m familiar with the arm/disarm process where you enter your PIN and press either STAY, AWAY, or DISARM. I can perform all of those functions from the ST app, but when I enter my pin on the keypad and then press a mode, I get no action. I did go into the device settings in the ST app and change my PIN from “0000” to my personal PIN, but still no love there. Any ideas what I’m doing wrong?

As previously mentioned, I’ve been a Ring user for years, but have always been curious about making a Ring Keypad (GEN2) work directly with ST independently of a ring account and base station.

I stumbled upon this thread and realized someone finally did it! THANK YOU!

I recently moved to a different house which is wired with an old school security system so I plan on converting it to Konnected and that with the Ring Keypad (GEN2) should be incredible.

Thanks again and TIA for your reply.

Figured out the driver issue so it looks like I’m good there.

Still cant enter a PIN to arm or disarm though.

If you have 2 drivers installed probably one of them is mine, and the second one is yours. My driver supports both, the US and EU version. If you just want to use my driver you can uninstall the second one (there is a limit of drivers about 50 (or 80 as someone reported that recently) per hub so it’s always good to uninstall the unused drivers.

What happens when you enter the incorrect PIN and click on Disarm? There should be sound and light notifying that the code is incorrect.
When you enter the correct PIN and click on Disarm you should see in the app that the button “Disarm” was clicked but nothing should happen in the keypad. You need to create the automation: IF disarmed was pressed THEN security system->disarm.

Any tricks to getting the keypad to pair? I was previously using rboy DTH. I excluded/removed my keypad. I installed the edge driver through your channel. I’ve been trying to connect/pair my keypad close to my hub but after several tries it won’t pick it up.

Do I need to delete the rboy DTH? Would that affect it?

How did you try to pair the device? You can follow the instruction from the RBoy post:

Is this zwave only or is there a possibility to get a zigbee version for other keypads?

Thank you hmorsti for your work on this.

I’m not a developer but I am getting desperate. So next week I’ll be fumbling through trying to copy/paste add features to this driver based on posts in this thread. Of course if there is a wiz already working on it I’ll gladly switch to test and report.

My first priority is enabling programming 3 individual codes. My second priority is making it visible to and enabling programming through SLGA which I presume will make it available to other services like the new Lock Manager as well.

1 Like

I am just now looking into keypad options for my setup and curious if this keypad works directly with Smartthings and does not have to be used through the Ring app.

Please let me know. Thanks in advance!

The Ring keypad can be used directly with Smartthings. The capabilities that are available to you are determined by the driver that is paired to the keypad.

1 Like

All set. It looks like I needed to first put the hub into pairing mode before holding the #1 button for 5 seconds. It would not work the other way around.

This driver is really robust and offers an awesome amount of config options. Thank you for your work. One thing I was able to do with Rboys DTH was arm/lock with the single press of the Arm Home button. From what I can tell so far, I need to first enter the pin before being able to arm the system. Of course I want the pin entered to disarm but for my use, there’s no need to enter a pin to arm the system. Is this possible with settings or with some automation/routine?

Picked up one of these to play with while this driver shakes out and other automation solutions are worked out with it. But I like where this is headed. Can’t wait to see how things progress!

x2, have an Iris iL02_1 and it’s zigbee, this would be a lifesaver!

Firstly, thank you again for your brilliant work on this project and also you’re responsiveness not only to me, but everyone on this thread. Do you have PayPal, CashApp, Venmo, Zelle, or other way I can send you a few $$$? I know you’re doing this as a labor of love for the community, but I’d like to contribute a little something to your efforts. The world needs more people like you.

Once the keypad is armed, if I enter the incorrect PIN, I get the error tone and the keypad flashes (which is normal).

The issue I’m having is that I can’t arm either stay or away modes or disarm those modes when entering the correct PIN. I enter the correct PIN and nothing happens on the keypad or in the app. I can perform all of those functions from inside the app with no issues however.

I confirmed that I’m using your driver so I’m good there. I can even get the keypad to respond to different button presses from a ZEN32 scene controller so that’s awesome too. It’s just the physical entry of the PIN to change armed or disarmed state that I’m struggling with.

1 Like