[ST Edge] Driver for GE/Jasco Z-Wave Motion Switches and Dimmers - 24770, 26931, 26932, 26933

I would suggest using the Z-Wave Device Config Mc to set the parameter since it doesn’t seem to be exposed in an operational driver. You change to the config driver, set the parameters, and then change back to whatever operational driver you are using. Your device may be removed from existing Routines, so you may want to record which Routines the device is included in.

@h0ckeysk8er This driver exposes every parameter available for these devices. Pointing someone to a configuration driver is counterproductive as this driver will likely erase any changes made with a different driver.

This is correct:

1 Like

As a clarification to users who need to use the Z-Wave Device Config Mc driver to configure any parameter or association group:

The driver does not delete or modify any configuration or association that exists in the device without the user expressly doing so.

Ideally, drivers should have all parameters accessible to users, like most @philh30 drivers, but this is not always possible for all devices and drivers.

I’ve got a 26933 Jasco dimmer/os and trying to upgrade the Edge deriver. I get an error message when using your GE Motion switch and dimmer driver. Any thin else I should look for?

Were you able to change to this driver? If so, what is the error you are getting?

No- I got the error below:

Notice that your manufacturer code is all zeroes? That means it is not properly associated with the hub and therefore no fingerprint to match in the driver. You need to exclude the device and re-add it to your network. Also, be sure to add it by either scanning the QR code or Add by Brand. If you are prompted to enter the DSK, do not skip it as it will cause S2 security to fail and can cause the all zeros issue you see.

1 Like

That solved the problem- Thanks!

I installed the edge driver, and I checked and it looks like it don’t fingerprint, I tried to switch it to you driver and it said it could not find the fingerprint, don’t know if it may even be supported or not.

Thank You

Looks like your device fingerprint is not in his driver. The sensor driver is now being maintained by @csstup. You should post in the Z-Wave Sensor Driver channel.

1 Like

Your device is a GE motion sensor, not a motion switch.

That being said, does the stock Z-wave Sensor driver not support what you need from this device? Z-Wave Sensor CS doesn’t currently support it either.

That makes sense, I was just looking for an driver like the old groovy driver that let you change option like sensitivity, delay, and whatnot. Thank you for the assistance.

If you just want to change the parameters, you can use a specific driver (Zwave Device Config MC) to do so (change to the Device Config driver, then change back to the stock driver).

I’d be happy to add support for it with a complete driver integration but I’d need a device sent to me to develop/test with. PM me if you’re interested.

Hi everyone!

I have 2 GE 26931 motion switches.

The switches used an old DHT so I excluded them in zwave utilities per the instructions.

Installed the new Edge drivers.

Reset switches and readded to ST. The drivers picked up right away.

The problem I’m facing is that the switches are showing offline or “There was a problem connecting” or “this device hasn’t updated all of its status information yet “

I’ve excluded/deleted/ re-added (inclusion) / restated the app / reboot hub but I’m getting the same issues with both switches.

Added screenshots.

Any assistance would be greatly appreciated!

Did you pair the switches near the hub? If not you might want to try that.i

Thanks - they are within 15 feet of the hub and worked perfectly prior the conversion.


Thank you for the driver! I open a ticket here in Github: GE Motion Switch - driver fingerprint not matching? · Issue #23 · philh30/ST-Edge-Drivers · GitHub

I installed the driver like I have several others, but something isn’t working. When I go to switch drivers it’s not being listed an an option to switch to. I’m not sure why not. Any thoughts?

Your fingerprint is already in the driver, so there’s nothing I can do on my end. Check the driver list in the app to see if it’s really installed, or try uninstalling and reinstalling the driver.

Yeah … “SmartThings” aren’t really smart lately. :frowning:

I looked … the driver is there!

Ha! But it IS my fault. I enrolled in your channel, but then didn’t view and install the correct driver. You had three of them and picked the wrong one. :-/

Thanks again for the great work!

Apologies for the thread ressurection but I think I could possibly be going crazy. I have my motion dimmer running on this driver and it works well (TY @philh30). However, I recently upgraded the hub and moved all my devices over. When I added the motion dimmer and set the driver, I noticed that there were no longer options for multiple presses. I could have sworn that I was using this edge driver and it had those options.

If I am crazy, which is a definite possibility, is there a way to get multiple button presses going, e.g. press twice to jump to 80%?