[ST Edge/Beta] Xiaomi/Aqara/Tuya zigbee sensors driver

Same here about the detection interval level. Reverts back to 30. He did mention something in the beginning about this not sticking. Did you ever get it to work? Also Sensitivity doesn’t work for me either. Stays on Medium.

I also have a human presence sensor that I’d like to get working. You may want to look at this thread.

A generic edge driver has been created that works with some Tuya devices. I’ve not had any luck getting it to work, but maybe you might. Hopefully we can get it working and share the results with others.

2 posts were merged into an existing topic: [ST Edge] Personal Tuya Devices - Generic EF00 Device

Any chance that Aqara Light Detection Sensor T1, GZCGQ11LM will be also eventually working with smartthings?


I have a Vibration sensor MOES showing as “Thing” in ST. After installing Driver “Zigbee Thing [YG] v1.0.2”, the device shows as “Zigbee Thing”, and only exposes Signal Strength (twice) as triggers.

Is there a way this device be added? Here are the initial required info:
Label Zigbee Thing
Name zigbee-thing v2.6
Id f706ba9e-d9b7-4a27-8839-86420cd750c2
Manufacturer Code _TZ3000_bmfw9ykl
Model TS0210
ZCL Version 3
APP Version 64
Zigbee EUI A4C138EBCD1D09AE

Capabilities refresh
Capabilities (groups) amberpiano10217.groupInfo
Capabilities (bindings) amberpiano10217.deviceEui

Product available at amazon:

Let me know if anything else is required to expose this device as a vibration sensor
Thanks !

Just added a new device TS0201, the smartthings app(android) keeps crashing. Remove the device and it works fine.

Crashes while I scroll thru the rooms via the devices menu.

Any suggestions? I have reinstalled and rebooted the phone.

Hi @

Is a issue with múltiple mosaic in new Android app versión

Delete driver Zigbee Temp Humidity Sensor Mc and install Zigbee Temp Sensor And Child Thermostat Mc

1 Like

Good Afternoon, @ygerlovin kindly add fingerprint to Zigbee Sensors Edge Driver [YG] , Aqara P1 door and window sensor, model MCCGQ13LM, is zigbee 3.0. I am sending the link for the Aqara P1 door and window sensor and also attached is the Zigbee Thing fingerprint of this Aqara sensor model. I had already placed the order last month (December 2022) so far I have not received a response from you regarding the inclusion of the fingerprint of this Aqara device and it still does not work on the smartthings hub using your driver. I am sending the fingerprint again and could you please add it to your driver.

Good morning, @ygerlovin , the Aqara RTCGQ13LM High Precision Motion Sensor motion sensor.
I paired it with its driver, but the status is not changing, it is getting stuck in any movement. When I try to make the movement it just stays in no movement. I’ve tried to delete and repair again, but the sensor is not working…

I feel like I’m being very silly, I add the channel and see these drivers:

Zigbee Multi Gang Switch [YG] v2.1.6
Zigbee Dimmer Driver [YG]
Zigbee Button Remote Driver [YG] 1.3.8
Zigbee Sensors Edge Driver [YG] 1.8.16
Zigbee Thing [YG] v1.0.2
Virtual Things Edge Driver [YG]

I have a MCCGQ01LM - Door and Windows sensor, what driver from the above list do I need to install to work with this particular sensor? Am I missing something?

I also notice that when I try to add the device that the app offers a Brand:Aqara → Open/closed sensor, does this imply that SmartThings have added their own sensor driver? If that’s the case then I’m struggling to add it despite the instructions found in this thread (5sec push/reset, 3 flashing flights, then keep pressing every second to keep the device alive). Help gratefully appreciated, likewise to Yakov for his incredible work in creating these drivers.

Assuming you fingerprint is present you would be using the “Zigbee Sensors Edge Driver [YG] 1.8.16”

Install the driver, put device in pairing mode, and use scan nearby. Do NOT scan by brand.

Thanks for the help Paul - This is what I have on the hub when I look at drivers:

I assume this is what you mean by fingerprint? I’ll try a scan (not be brand), which I did already try with no success…

The fingerprint is the device identifier. You can find it in the old IDE under I think data. Or in the new API Browser+.

For a ZigBee device it will look something like this:

model: “83k2xfd”

Aqara devices can be very difficult to pair. Pair it right next to your hub. And maybe be keep pressing the pairing button even after the process starts.

I removed the particular Aqara sensor from the old IDE as I also needed to remove the old groovy based device handler; based on this I don’t have it connected and therefore can’t see the fingerprint; unless (very plausibly) I’m missing something?..

I am close to the hub as I know zigbee has a tendency to use it’s mesh network… I’ve also been pushing the button a lot! I’ll go try again. You’re not wrong about the devices being difficult to pair but once they run they’re really great in cold weather!

Thanks once again for your help.

I have a couple Aqara buttons. They work great, the batteries last but they can be a major pain to pair. One of the buttons I needed to remove the battery and let it sit for a while before it would pair.

If you can get it to pair as a thing you can get the fingerprints.

@Mariano_Colmenarejo has a driver called ZigBee thing that can be used for that purpose.

Battery is out! I’ll give it some time before trying again, I have an Aqara Motion Sensor and recall that also being a major pain to pair when switching it to the edge driver.

I suspect the API Browser+ can also be used to view fingerprints? I did play with the CLI sometime back but didn’t want to invest tons of time as I had other things going on, now Webcore/Groovy is off I have to fix some of my stuff…

Thanks for the link, I now have the “Zigbee Thing Mc” installed, how do I use it?

It might pick up your device during pairing or you can change to that driver after pairing to see the fingerprint.

After rereading the 1st entry in this thread says Your device is supported so if you can get it to pair you should be good.

Just tried again having left the battery out for a while, still no luck! I’ll try again later. I will also see if I can check the model number; I’m pretty certain the image in the first post matches what I have.

Just to follow-up, I left the battery out for days, that didn’t help! I then spent half an hour trying literally everything, including a reboot of the hub, various rates of clicking to keep it awake; resets, iOS and Android phones, etc. etc…

In the end I gave up and just as I was walking away I got a message on my Android phone that an Aqara Door/Window sensor had just been added! I don’t recall the exact message and have no idea how this happened but it did! Anyway, it’s offline again now, that’s another problem! I did have time to validate that the driver is the one developed by Yakov.

Hi @ygerlovin !
I have the “LCD Temperature & Humidity Sensor”, Model ZG-227ZL manufactured by Tuya (Zigbee ID:_TZE200_znbl8dj5/TS0601).
Could you please add that device to fingerprint?
A big thanks!