[ST Edge/Beta] Xiaomi/Aqara/Tuya zigbee sensors driver

I don’t understood this, so I am asking:

I have found that

I think it was a description error.

Hi @ygerlovin can you add this one , its Moe’s temp and humidity display , it’s working only for temperature on the smartthing beta driver like this , no battery , humidity is divided by 10 so if it’s show 54 %on the display in the app it will show 5,0%.

Thank you

You might ask Mariano to add this one. Since it doesn’t include the EF00 cluster he would probably be able to

For the folks that are using the FP1 with this driver, do you have any tips on getting the device to pair? I tried many times holding the pairing button for 5sec until it blinks, but can’t get it to pair. I am already using this driver with Tyua temperature sensor and works well.


@witchrobin I found going through the steps of an Aqara contact sensor and scanning the code worked.

1 Like

@Alwas That worked perfectly! Thanks for the tip.

1 Like

Good afternoon, @veonua e @ygerlovin does the Aqara P1 Door and Window Sensor model: MCCGQ13LM with Zigbee 3.0 already have a driver or not? Has anyone sent a fingerprint of this Aqara sensor? or is it already working in some driver?

illuminous sensor is very erratic in aqara. it does not show the correct value most of the times. Sometimes it shows a very very big value

Motion need to be trigger to have illuminous update

Hi there, after many attempts I was able to pair a vibration sensor DJT11LM and it shows up as a “vibration sensor” in the ST app and in the IDE it has a placeholder type. The issue is that I’m unable to do anything with it. I can’t open it in the ST app. Nothing happens when I tap on it. I can long press and edit the room it belongs to but that’s it.‏
‎ ‏
‎I installed the Zigbee Sensors Edge Driver [YG] 1.8.16 drivers and it has the name “Vibration with threeAxis battery voltage (YG)” which indicates that it’s using the correct driver. ‏
‎ ‏
‎Is there something else I need to do in order to get this to work?‏
‎ ‏

yes . It does trigger and update but the values are not correct

I said this in another thread but it’s probably better suited here.

I just bought a new high precision motion sensor from ali. This is my first experience with aqara.

I got it to connect to the hub and I have it using yakov’s driver at the moment. So all good there. Except for the fact that it will not detect motion, no matter what I do.

So far not super impressed with aqara :rofl: but I hope someone here can point out something I’m missing

check in the logs.

I had one defective unit it used to send messages only the first couple of minutes after pairing, then stopped whatever I did.

1 Like

I would say that’s probably the case for me as well. I last tried to add it at 10:16 last night. The logs show the settings on the device through 10:17, then nothing after that. This morning it is offline.

I am fairly confident I have it added to the hub correctly, but I wanted to make sure I don’t need to change a setting or do something physically to the device itself to get it started. The instructions are entirely in Chinese so it’s very possible I was missing a step :rofl:.

Now to figure out how to ask aliexpress for a replacement…

also, try to change the battery and check the battery contact. I fixed one of the devices just by bending the contact with a screwdriver to make it fit better

1 Like

Thanks. I’ll give it a look. I did think it was a little strange that there was no pull tab or anything blocking the batteries. Meaning they theoretically could have already been running for awhile.

Changed the batteries and did bend the contacts a bit and sure enough, it is working now. Props to you, my friend.

1 Like

Sorry, new to using smartthings for Aqara / xiaomi devices. I’ve added a couple of contact sensors however the app always says “Couldn’t get device’s status” but if I review the logcat of my hub I can see the sensors and their events being triggered (open/close sensor boolean turning on/off). Is this a bug with the smarthings app or have I potentially missed something? Just seems strange that logcat demonstrates that the device appears to be working fine but the app is just gimped and offers zero insight into the device state.
Similarly the “Aqara Motion Illuminance sensor” does seem to sort-of work in smartthings app (though the values are often ‘stale’ and I regularly get “Couldn’t get device’s status” messages when reviewing the state.) Similarly the logcat seems to suggest it’s working just fine.

Presumably if the smartthings app isn’t reliable then any 3rd party I would want to use like HomeAssistant/OpenHab would be unreliable as well.