ST Classic after Nov 15 update - Presence no longer works, icons missing, app crashes

I am having same issue Nov 20 my presence stopped working. I did clean install without removing presence. I’ll try your steps and see if that works.

I just successfully rolled back ST Classic app to version 2.17
got my icons back, no more crashing
I turned Off auto update

Still doesn’t work for me, I’m going to try rollback

How are you guys rolling back? Downloading from somewhere like Apkpure or is there a rollback feature in the Play Store I don’t know about?

Classic app on Andriod crashes pretty much every time I open it since the update, usually OK second time.

https://www.apkmirror.com/apk/smartthings/smartthings-smartthings/smartthings-smartthings-2-17-0-release/smartthings-classic-2-17-0-android-apk-download/download/

ST Classic version 2.17

Turn Off Auto Update

Remove phone as a presence sensor

Completely Unistall 2.18

Install 2.17

Add presence sensor

Reboot phone

1 Like

2.18.1 solves presence and crashes for me but not the problem with missing icons

1 Like

I received this reply from Smartthings Support yesterday:


Thanks for writing in.
I feel sorry for the inconvenience you have experienced. We have identified that a lot of users are experiencing a similar issue with the new update on the Classic app.
I would like to inform you the last update made some changes to the app with the app crashing and mobile presence not updating.
Our developer teams are currently investigating on this app update. The issue will be fixed shortly. We do not have any ETA’s at the moment as this update came just now and the developers are working on it.
Just to keep you informed, this is the final version of the SmartThings Classic app. As all users will soon switch to the New SmartThings app, the old app will not receive version updates.
For mobile presence purpose, we recommend to please log in to the New app and see if the mobile presence updates, if you are still experiencing any app crashes write back to us.
Thank you,
Shailaja
SmartThings Support.


I have a hub v2 (2015), motion sensor and switches. The main reason I bought into Smartthings was to be able to arm the house when I leave through mobile presence so I could get alerts if there was motion detected. Every time I try to use the newer app, I try to add Smartthings Home Monitor by adding automation, but it is not offered to me (I’m in the US). Is there a way to do the same automation in the newer app as I have in Classic?

UPDATE**
Since posting I have learned three things…

  1. They have released an update to Classic which fixes most problems.
  2. I am now running the newer app. It has much more functionality than it used to have. I have successfully duplicated all automations that I had in Classic. There is a learning curve for those coming from Classic.
  3. If you switch over, I would delete everything from the Classic app (don’t just uninstall the app) before you uninstall the app. I would also login through the web, check to make sure everything has been deleted, and delete anything left, including your hub. Create a new location, make it your default, then delete your old location. Then do a factory reset on your hub. This will make things problem free. If you leave things set up under the old app the new app doesn’t handle things very well.

To me too.
It’s strange because my girlfriend’s Huawei P30 Pro also with the latest version shows the icons.

Sometimes Smartthings is like Facebook: is never 100% reliable. :angry:

And they want to force users to switch for the new (bad and confusing) app?

Smartthings Classic was updated again, 3 hours ago

Mine is 2.18.1 and there isn’t any update.
Which one do you have?

Two updates today to get to 2.18.1 - now opens without crashing

Yes, that’s the one i have since Tuesday (i think), and yes now it doesn’t crash the first time we open it, but the icons disappeared to some of us.

Standard icon categories are listed, but opening each, are empty. No icons to pick from. Freshly updated Classic version 2.18.1, Build 561929

I have 2.18.1 since couple days ago. Than app gets updated again to 2.18.1. Probably something is different.

I have the exact same issue and notified support and was given a BS answer as well.

Reluctantly updated to 2.18.1. Icons still missing. Presence works but then thinks I left when I didn’t, so lights will come on when I get home for about a minute, then turn right back off.

Everyone,
backing out to the older version 2.17 works. I don’t know about presence but you get your icons back. I’m not an expert on smarttings but I’m a computer engineer and know more than the average person about Android. I think the reason you see some people saying that their icons/presence stopped working on their phone but not others in their household is because this is a Android 10 problem especially the latest updates to Android 10 (which if you have a Pixel means you definitely have the latest). Google is rolling out a new feature called “Scoped Storage”. This silos applications permissions to write or read just any storage it wants. i.e. if an application needs permission for storage but it is only to write pics or docs, then it no longer has a carte blanche access to storage it can only read/write to the area where say pics are stored. This is messing up a lot of developers apps because they didn’t have their app ready in time and Google apparently is not waiting …

This is what worked for me although it doesn’t make sense.

My issue. Around Nov 15th all mobile precense stopped. Fobs continued to work. I uninstalled the app completely from my Pixel. Waited 4 days. Reinstalled Classic. Logged in. Gave all permissions requests the thumbs up to run persistent in the background for no battery optimization and location access. Immediately… And this is the strange part… Both my wife and my phones registered precense. Why replacing my app affected my wife’s presence I’ll never know.

Now the remaining issues that linger are my devices don’t show up unless I click back and forth into other screens and various buttons in devices don’t render. Example is my Ecobee shows the temp settings but not the arrows to go up and down. The buttons work but I have to guess what to press.

I’ve used the new ST app before. I’m reluctant to upgrade as it did not handle automation as well as classic. The If then else process was nowhere near as effective.