ST app on iPad - cannot login (spinning icon)

I have latest ST app for my iPad (1.7.09.16). Once it loads, if I tap on [Sign In] button, nothing happens other than a spinning icon.

Using same version of ST app on my old iPhone7, after loadin, it immediately goes to the dashboard. So on my iPhone it remembers my ST credentials, no login needed…

I remember emailing ST support a couple years ago about this same issue - and they advised me to “clear cache”. I said I don’t think the ST app has a cache one can clear. They replied “clear your browser’s cache”. I have multiple browsers - which one does the ST app use (in the background)? Assume my default browser (Firefox)? I tried clearing all cache data in FF today, but still can’t login with ST app on my iPad (running iOS 16.3.1 on iPad mini 6th gen).

Any suggestion?

TIA,
Mike

On iPad, go to Settings → Safari → Advanced → Website Data and search for SmartThings or Samsung and remove.

Thanks, but clearing Safari’s website data for SmartThings.com made no difference :(. Even tried clearing ALL website data. In ST app after I tap [Sign In], progress gears spins for about 45 seconds, then it’s back to the same initial startup screen. No error message…

Solved by enabling my iPad’s default browser (Firefox) to be able to run in the background. i.e. Settings->General->Background App Refresh->Firefox

1 Like