Sonos - Possible Bug : Audio Resuming even when not playing prior


(C Schwartz) #1

I believe I have found a bug with regards to Sonos Playback based on Mode and Presence with multiple playbacks.

I have the following defined:

Mode Set To Home: When Mode Changes to Home a Message is played that States: "Mode Set to Home"
Resume currently playing music after notification is defined and enabled on this action.

Chris has arrived: When my iPhone arrives home a message is played stating: “Chris has arrived”.
Resume current playing music after notification is defined and enabled on this action.

Girlfriend has arrived: When my Girlfriend arrives home a message is played station: "Girlfriend has arrived."
Resume current playing music after notification is defined and enabled on this action.

As you can see I have defined on each of these actions to resume playing current channel in case someone is home and listening to music or if I have left the music on for our dogs while we are gone.

Issue Identified: If any of the actions fire on their own it works as anticipated and the stated message is played. It appears in the scenario where currently nothing is being played on Sonos. (i.e. stopped or a current audio has been paused.) and multiple actions occur in the same period. i.e. the girlfriend and I arrive home at the same time due to going out and coming back together Sonos will start playing the last played audio stream no matter if it was stopped or not playing prior to arrival.

Therefore, in this instance if audio is paused or not currently playing it should not start the music playing.


(John Mielko) #2

I have same bug… any fix?