Sonos - Play radio station - unless already playing something

sonos

(Jocie) #1

I’ve set up the Sonos Mood Music SmartApp to play a radio station when motion is detected in my bedroom, however it triggers every time there’s movement, so every 2-3 seconds while you walk around the room or move in bed there’s a moments pause while the station reconnects. Annoying, as you can imagine.

So my question is: is there a way to prevent Mood Music from starting the radio station if Sonos is already playing something?


(Andrew Chorley) #2

not that I know of, home automation is still very dependant on people having a good technical understanding to make it actually work well. BLE will make home automation that much more useful.


(Shane Schwarzman) #3

I have mine setup this way for my shower, and i’m not experiencing this. I have mine set to turn off after no movement is detected. I also have all my stations set to a virtual switch that turns on the mood music. the switch turns off after no movement.


(Edward Pope) #4

Using the virtual switch as @KingStrava has done works best with what you are trying to accomplish


(Jocie) #5

I’ve added virtual switch, but I’m not sure how to configure Sonos/the switch to do what I need which is something like this -

  1. When movement is detected
    a. If Sonos is playing - do nothing
    b. Otherwise play a specified playlist
  2. When movement is not detected
    a. If Sonos was previously playing - do nothing
    b Otherwise stop the playback

(Sully) #6

Insead, when movement is detected, turn on switch.

Then, you can hopefully use the Sonos App you’re using now to play based on the switch, instead of motion. When motion stops, the switch turns off. It won’t let you know if Sonos was already playing, but that may still fuction within the Sonos app (don’t have Sonos, so I’m no help on that part).

As for using the virtual switch, you just trigger the Sonos app off of the switch instead of the actual motion.

Does that help?


(Jocie) #7

I will give it a go, thank-you everyone for your input!


(Cody Farmer) #8

So when I first set this up with my new sonos it had about 7 different of our pandora stations. Now as I’m changing things I now only have one station to choose from in mood music. I added favorite channels in sonos app and tried playing them first but I still only have one choice. So how do I get ST to notice different stations like country or rock from my play list or favorites. I’m not doing something. Help please. I just want some country music to play when my wife gets home so she approves. It worked once but not anymore. Thanks guys


(Tony - SmartThings Unpublished Contributor ) #9

Try: Play the desired station / playlist on one of your speakers, then go to that Sonos Player in the ST app and hit refresh. The station/playlist should now appear as an option. Repeat as necessary.

If that doesn’t work, I suspect that your speakers (understandably) hate country music. :sunglasses:


(Cody Farmer) #10

lol yes I could understand that they agree to agree with me on County music but we all know the WAF. soooo…I need this to be easy. I will try your method to refresh my ST station options. honky tonk