Sonos hard wired vs. WiFi


(Greg Powers) #1

Can I install my Sonos Play:1 as a hardwired ethernet device instead of a WiFi device. The option is offered in the Sonos set up. But I can not seam to get the SmartThings hub to discover the Sonos Play:1 device???


(Morgan) #2

Is your Wifi on the same subnet as your ethernet ?


(Greg Powers) #3

yes, they are all on the same subnet. Airport extreme is on 192.168.1.1, Sonos is 192.168.1.10, SmartThings hub is 192.168.1.2.

Plus I can control the Sonos from my iPhone, so the iPhone is on WiFi talking to the Play:1 which is on a wired connection. BUT SmartThings cannot fine the Play:1???


Is Philips Hue the neglected one and TCP the favored one
(Greg Powers) #4

here is a live trace. It look like the Sons is being found But has a status of trace Device was already found in state…"

Trace start =========
415cd104-6545-4526-858c-4e720eaa988a 9:27:02 PM: trace ip:192.168.1.10:1400
415cd104-6545-4526-858c-4e720eaa988a 9:27:02 PM: trace dni: C0A8010A:0578
415cd104-6545-4526-858c-4e720eaa988a 9:27:02 PM: warn UNVERIFIED PLAYERS!: [uuid:RINCON_B8E93785DC8801400::urn:schemas-upnp-org:device:ZonePlayer:1:[port:0578, ssdpUSN:uuid:RINCON_B8E93785DC8801400::urn:schemas-upnp-org:device:ZonePlayer:1, mac:B8E93785DC88, devicetype:04, hub:c2c22a69-1dcc-4671-8b3e-2793523c18bc, ssdpPath:/xml/device_description.xml, ssdpTerm:urn:schemas-upnp-org:device:ZonePlayer:1, ip:C0A8010A]]
415cd104-6545-4526-858c-4e720eaa988a 9:26:59 PM: trace Device was already found in state…
415cd104-6545-4526-858c-4e720eaa988a 9:26:59 PM: trace sonos found
415cd104-6545-4526-858c-4e720eaa988a 9:26:59 PM: debug Executing lan discovery urn:schemas-upnp-org:device:ZonePlayer:1 on Powers Residence Hub via sendHubCommand
415cd104-6545-4526-858c-4e720eaa988a 9:26:55 PM: debug Executing GET /xml/device_description.xml HTTP/1.1
HOST: 192.168.1.10:1400

End trace ========

The Play:1 was found on the SmartThing Hub previously but was uninstalled because two Sonons (Connect) smartApp were showing. When I deleted the one not being used, the remaining Sonos (Cone t) smartapp stopped working.

So how do I get SmartThings to completely forget the Play:1???


(Greg Powers) #5

Not sure what happened. We were on vacation for a few day before Christmas. During our time of being away I got a blue exclamation on the big plus sign. When I look the Sonos had been added. When I got home 3 days later I tested it and it worked.

I have no Idea why it (Sonos in SmartLabs) started working when I was gone. BUT the Sonos was hard wired and did not have WiFi defined.

First I tested a voice warning for the garage door, it worked. Then I unplugged it and moved it to a more permanent location and connected the ethernet cable. Again I tested and it worked.

SO for now I will build the remaining 6 or so voice warning when door open and see how it work for a while.