Sonos Connect Issues


(Eric) #1

Hoping someone has an answer to my Sonos problems. I’m pretty sure I’ve seen other posts indicating that the Smartthings connection to Sonos has its issues. I’ve been consistently getting this response when issuing play/pause commands the last week:

com.netflix.hystrix.exception.HystrixRuntimeException: C*-DeviceData-Get timed-out and fallback disabled.

I’ve tried removed the speakers from Smartthings altogether, but I’m still seeing the same problems. Does anyone have some tips for me that could possibly alleviate this? I know the Sonos Connect is still a “Labs”, but I’m hoping to make it at least semi-functional.


#2

try removing sonos from ST, then change the name of the sonos in the sonos app, then readd back to ST.


(Greg) #3

I’m seeing this also


#4

As am I. Removing and adding back the device(s) doesn’t produce a different outcome.


(Scott) #5

I’m experiencing this issue as well, and would appreciate a resolution from Samsung.


#6

I tried a 3rd device and it had no problems, so I chalked it up to extremely bad luck and sent the two failed devices back for a replacement. If it’s not too late for you, I recommend doing the same.


(Scott) #7

Thanks for the tip - I will contact Samsung support and ask for that (just picked the device up last week)!


(Paul Barden) #8

Surely this is a software issue and not a hardware one??. I’m finding I have this issue also. It’s extremely frustrating to have to uninstall all my rules that use the Sonos, remove the device, reconnect, repeat.

Is there a custom app other than the Sonos connect that perhaps is more stable. thisnis the only thing right now about my setup that sucks. Everything else I’m happy with.


(Eric) #9

I did quite a bit of searching and couldn’t find anything other than the Sonos Connect provided through the Smartthings marketplace.

However, Smartthings has actually been performing flawlessly with my Sonos system for at least the last 7 days. I’ve also added a Play:5 since then as well, with no problems.

Hopefully the platform stability keeps improving fingers crossed