[SOLVED] Post-Migration - Stuck on "Processing" for all SmartApps?

So…post migration it seems I’m just getting a spinning “Processing…” when I try to use any SmartApps. I tried uninstalling the SmartApp then readding - can’t even re-add. Get a network error and then “Processing”.

Anyone else encounter this? VERY frustrating and not sure how to even start to resolve.

SOLUTION: Whitelist useage.trackjs.com in PiHole/ad blocking/firewall rules.

Are you using adguard, any malware blocking or have a pihole on your home network?

My guess… pihole :slight_smile:

If yes, respond back and we can tell you how to resolve.

I do have a PiHole. I turned off blocking, it still happened, then I posted here.

Now…it’s turned back on and it seems to be somethings are working? So…kind of confused. (Or…maybe not…)

Guessing there’s something I need to white list?

Whitelist usage.trackjs.com

Turning off never resolves it, whitelisting does :slight_smile:

I also get the replies that you can click on that url and it works so why the need to whitelist? You do

1 Like

And that was it. Thanks! Kind of…annoying.

Yep, at least you got the processing (or at least mentioned it) which made it easier to identify

You may want to mark the thread as solved in case others search for this topic.

Done. And good idea. Now to dig up some other questions (e.g., do I even need webcore anymore or is it all built in, etc. - not clear at all what SmartApps have been integrated, to what level, etc., in the new app).

If you are currently using webcore and like it then you may want to contInue using it for now. Only note that WebCoRE can not control STHM state directly in the new app like it could with SHM in the Classic. Plus automations still have a few quirks to work on. You may want to skip pre-conditions at this point. But a new Android app version was released today which may contains fixes.

WebCoRE can no longer execute routInes so you would need to edit those out. If using push notifications in webcore, you would need to edit to send push notifications and store in messages in order to get them to work with the new app.

Note: I use both webcore and automations. I have converted many pistons over to automations.

:+1: Thanks. That makes sense. Seems a ton of ‘wait and see’ stuff around Echo Speaks, what will be possible with WebCore in the future, etc.

I don’t think I was using any routines before anyway - I don’t think. :slight_smile: Most of my stuff was in WebCore calling scenes and the like from Virtual switches, so should be all good. Worried about them going poof is the biggest thing I guess. The only thing I have that’s complicated enough for WebCore still (I think) is my basement setup where motion lighting gets toggled based on the state of real lights and there’s a number of ‘scenes’ (movie lighting, TV lightning, PSVR lighting, etc.).

Thanks much for all the help, really appreciate it.

Don’t you all mean usage.trackjs.com, not useage.trackjs.com ?

You try typing on a tiny, winy screen and sea how well yuuu type :wink:
And have a dog and cat constantly wanting to assist with typing

And getting old and blind and so on


Last week I was typing account.SmartThings.com incorrectly

So…this had no effect and it was something else that resolved over time then. :slight_smile:

The last part of the url is probably all that matters… trackjs.com that you whitelisted.