SNH-V6414BN not detected by SmartThings

I recently purchased a Smartcam since there have been a steep rise in stolen packages in my neighborhood - including someone stealing an empty box because I had not broken it down for recycling but wanted it out of the house (back on the porch). While I am amused they stole an empty box, this makes me concerned about the safety/privacy of my home in general. ANYWAYS… on to the problem.

I followed the instructions out of the box, downloaded the app from google play, went through the setup procedures, was told the camera needed a firmware update (it installed fine), setup various passwords/settings and can view it from the web in IE (UGH) and on my phone - so far so good.

Then, because it was listed as supported (with caveats about motion notifications, etc) I wanted to get it added to my V2 SmartThings hub. I follow the instructions again in both the packaged documentation and the Android Smartthings app UI for my specific device, and then it sits there spinning on detection.

Forever. It never actually gets detected. How can I nudge it into action and get my SmartThings system to find it?

Why didn’t you go to Marketplace in the SmartThings app and install it from there? Just go to things then cameras, then choose the first one and follow the directions.

Where do I find it in the marketplace? there is no category for cameras, it’s not listed under security, etc. I can’t find the ‘Smartcam HD Pro’ smartapp that I’ve seen other people reference.

Open the SmartThings app, at the very bottom of the screen are five icons the second from the right is the Marketplace. Open the marketplace, and at the top is “THINGS” open that and the fifth item down is cameras. Then open that and choose the Smasung SmartCam 6414. Of course yours might look slightly different, I am on an iPhone 6s.

Ahh, I see what you mean. Yes, this appears to be an alternate method to the steps I described in the opening that could not auto-discover the camera. going through the marketplace rather than simply ‘things -> add thing’ get to the same place in the end.

For sanity sake I tried it again just now using this different path than what I tried before and it’s still just spinning on discovering the camera after 5+ minutes.

Are you selecting connect to existing camera or setup new?
Should be existing camera after first seting up the smartcam app.

However mine will connect just fine but they will no longer steam any more.
Hopefully yours will work!

The solution was with my wifi. I have an ASUS RT-AC3100 and since the camera connects on 2.4ghz instead of 5, there was an option about wifi legacy support. I changed ‘auto’ to ‘N-only’ and everything clicked into place finally.

6 months later…Just getting my Smartthings Hub set up with some devices and trying to add this camera SNH-V6414BN, but it’s no longer in the list of cameras in the Marketplace. Anyone know how to add it manually?


Not sure - I took a peek at the ‘add device’ list and all they have are netgear or ring cameras listed, but my cameras that I added a long time back are still there and functional without any special hoops/tricks to do. My only bit of advice would be to use samsung’s app to do an initial setup and update firmware and see if perhaps they get auto-detected as one would expect rather than having to manually add, where they aren’t on the list anymore.