SmartTiles: Video Camera Compatibility

dashboard
smarttiles.click
smarttiles
cameras
project_cameras

(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #545

Have you set the Media Tile type as “Still Image” (previously called a “Static Image” and input a Refresh Rate?


(Jason Moody) #546

Yes it’s working perfectly as a series of still images. But as a video feed it doesn’t move, just displays the first frame


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #547

That’s because, I believe, you are requesting only a “single image snapshot” with the URL.

That URL, if I’m not mistake, is not for a “video stream”. It’s just “get_image”.


(Rajan Kannan) #548

Can someone tell me some cheaper cameras that works with smarttiles/actiontiles? I need to be able to see live feeds on my smartiles dashboard.

Thanks in advance,


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #549

Hi Rajan,

This is a good place to post this question; but I also recommend ActionTiles’s own Forum where we have a Video category.

There are 2 general Questions like yours open; so I hope folks make some recommendations soon:


(Rajan Kannan) #550

Thank you @tgauchat. This is helpful.


(Justin) #551

I had a question about this as well.

I out in the get image URL and set a refresh but there is no refreshing of the image unless I refresh the page.


(Justin) #552

Also… another question. I use Synology Surveillance Station for the bulk of my camera work. As I can’t stream using the Foscam C1 directly has anyone figured out a way to use the Synology Surveillance Station to stream as an AT?


#553

Use this format to connect to diskstation:
https://[ip address]:5001/webapi/SurveillanceStation/videoStreaming.cgi?api=SYNO.SurveillanceStation.VideoStream&method=Stream&version=1&_sid=[sid]&cameraId=[id]&format=mjpeg


(Justin) #554

THANK YOU!

Last one. Do you know the same url stream for image get.

I have the samsung smart hub refrigerator and the browser will not play the video feed.

At least I can get the image and refresh.


#555

Try this:

https://[ip address]:5001/webapi/entry.cgi?api=SYNO.SurveillanceStation.Camera&method=GetSnapshot&version=1&_sid[sid]&cameraId=[id]


(Justin) #556

Perfect… worked like a charm


(Owais K.) #557

Any one connected Foscam to action tiles? I have Foscam FI9800P. Any help would be appreciated.


(Michael Hess) #558

http://IP Address/videostream.cgi?&user=username&pwd=password


(Patrick Mjoen) #559

I have the same Foscam FI9800P camera and was unable to get a stream, i have it take image snapshots every 15 seconds. I use the following URL

http://IP:PORT/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=USER&pwd=PASSWORD&

Per this link your suppose to be able to enable MJPEG stream:

http://foscam.us/forum/how-to-fetch-snapshots-and-mjpeg-stream-on-hd-cameras-t4328.html

Ive never been able to get it working though… The below link says it isn’t supported on this model:

https://support.aartech.ca/index.php?/Knowledgebase/Article/View/261/1/foscam-hd-camera-mjpeg-stream

All new camera’s have been Amcrest instead of Foscam.


(Camilo Herrera) #560

Hi all, anyone using a Dlink DCS 2330L ?
Thanks


(Camilo Herrera) #561

Sorry, I got it to work.
here is the address I used inc case someone else has the same issue.
http://admin:PASSWORD@IPADDRESS:PORT/video1.mjpg
It is working properly on IE and Chrome, but is no coming out on my Table running Fully Kios


(Chris Schoepp) #562

Hey all,
I am using Foscam RI9800W’s and I am able to get an RTSP stream to work.
However as I am trying to use actiontiles live streaming, this isn’t supported. I’ve tried switching my feed to MJPEG and using a format similar to below:

http://ipaddress:port/cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=ADMIN&pwd=PASSWORD

I am having no success with this. Am I using the wrong URL format or does this camera not properly support MJPEG?

If it doesn’t, can I forward my RTSP stream somehow to an MJPEG format?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #563
  1. I don’t know 100% for sure, but it is quite possible the camera does not provide and MJPEG stream.

  2. What are you using to view the RTSP stream? (Exactly which browser, OS version, hardware, please…).

  3. “Trans-coding” from one video stream format to another is possible using VLC or various other types of server based processes (including Blue Iris and cloud services). It is one method that might be a way for ActionTiles to handle a lot more cameras, but it isn’t an easy answer either.


(Chris Schoepp) #564

It seems from my research that similar models don’t have an MJPEG stream. I was using VLC to view the stream, pasting the link into the network stream link. I haven’t found a browser that worked so far. Do you have a recommendation for transcoding? I have a raspberry pi I could use to host whatever is required if that’s useful info. I’d prefer to keep it in-house as opposed to an internet solution so it’s more secure.