SmartTiles: Video Camera Compatibility

dashboard
smarttiles.click
smarttiles
cameras
project_cameras

(Kevin Todd) #443

Ah, well, I use a dedicated in-wall Pi on a touch-screen for this. If you are accessing smart tiles from a browser, this would indeed have ramifications for all sites you visit. You could shortcut a launcher for chromium (which is what I use, not chrome itself).


(Kevin Todd) #444

Mase, I simply invoked the above switch and removed the incognito switch. This was only needed for my Amcrest camera, the rest of my various cameras didn’t need it. Below is my chromium auto-start line that launches when the pi comes up. (Removed my personal GUIDs of course)

@chromium-browser --allow-cross-origin-auth-prompt --kiosk http://smarttiles.me/?app=xxxxxxxxx


(Mark De Vane) #445

Hi All - Just started working with Smart Tiles after picking up Smart Hub this week. After some serious review of this thread, and some deep googling I have been able to identify a way to provide live streaming of HikVision cams using ST. As we know, RTSP protocol/plugin is not available in most standard browsers. I found a document on their European site, which explains how to configure the camera to support HTTP streaming using MJPEG.

Step 1 - Configure the camera to output mjpeg on the substream.
Step 2 - Once configured, use the following URL structure:

http://admin:password@[IP_Address]/Streaming/Channels/102/httppreview

where 102 = substream on channel 2. The rest of the variables (admin, password, [IP_Address]) would be replaced with your specific details.

I tested this on Chrome on a Mac initially before adding the code to ST. Hope this helps all the Hikvision owners out there.


(Smuts) #446

I noted this on this thread last month (9/27), but I couldn’t get the stream to stay alive for long. The
bigger problem was that I could only get the stream on one client at a time. Have you been able to stream to more than one device? If so, what camera firmware are you running?


(Mark De Vane) #447

Smuts - I have not seen the “keep alive” issue on my system so can’t comment on that. I agree that only one client can access the stream at a time. I tried other user names which are set up in the camera, but that does not solve problem. It may be an issue of power in the camera processor.

You might be able to help on this next point as I am so new to SmartTiles. What I am attempting to do to workaround the single user access problem we have both seen is the following:

Option 1:

  1. I have been able to access the snapshot stream which does appear to allow multiple users at a time. So, set up multiple snapshot tiles - one for each camera and let them update every “X” seconds.
  2. Would like to then set up primary “room” dashboards (Kitchen, MBR, etc.) with Snapshot Tiles and then link to a “live” Cameras Dashboard, which in turn has all the live feeds.
  3. This does not eliminate the possibility of someone else logging onto the Camera’s dashboard at same time as another user, but it “minimizes” the problem of broken tiles on the primary dashboard in each room.

Option 2:
I currently have not had time to determine whether Smart Tiles has the ability to create a “hot-link” directly from a Snapshot Image to another web page which has a much larger “live” image. Once done, user would somehow click back to main dashboard.

Option 2 (for me) is a better workaround since it puts less stress on the primary dashboard and minimizes multi-user camera access even further than Option 1.

Do you happen to know if hot-linking images is possible in Smart Tiles?

Regards, Mark


(Smuts) #448

I haven’t explored making a tile link to another page. Someone here will surely know.

I have a bunch of tablets and a couple old phones running ST. I’m using the snapshot URL for the cameras and have them configured as stop motion cameras in ST. I have them updating every 5 seconds. More frequent updates put too much of a load on the cameras. (btw. I isolated all the cameras and the wifi for ST on it’s own switch and wireless access point.)

If you just want a way to view the camera feeds on multiple tablets, use the rtsp stream and configure Tiny Camera Pro. I’m running another app called IP Camera Pro on my ST tablets as a motion detector. It wakes up the tablet via Tasker. It’s been working well for 3 days. . … . I can connect to the stream on these using Tiny Cam as well as my Hikvision cameras. It’s a nice little app.

Worst case, you can simply have a shortcut to it on your tablet’s main page. Switching over is very fast. Tiny Cam is speedy, even on a slow Kindle Fire.

I have my main cameras connect to Synology’s Surveillance Station. But I don’t want to run their app all the time. It’s too taxing on the server. Streaming to a browser is easier on it for some reason. . . . .

Other people here have much more sophisticated setups. I’m new to this as well.


#449

Hello all-

I see 400+ responses on this thread and really don’t want to read them all…LOL

This may or may not have been previously asked, so I apologize in advance if that is the case. I am new to security camera and I am trying to figure out what is my best option. I purchased the new Arlo Pro Series and though I do like a lot of the features, the fact they can not stream video thru Smart Tiles is a huge disadvantage. I like the idea of walking over to my in wall tablets to see if there is any action going on while home i.e. Driveway or front door. I recently downloaded Blue Iris and have been working thru that program, though it is a little complicated, but does seem to offer a lot of features I like, plus I can stream using this program to Smart Tiles.

I have a QNAP NAS I use mainly for Plex and was thinking of using this for storage?

I really want wireless camera, as running POE would be hard in my home at the moment. I have been looking at the Armrest 1080P Bullet Cameras? Also, I do not want “White” cameras, as they will stick out like a sore thumb on my home. Black is my preferred color of choice. Audio would be nice, but not a must.

With Armcrest App, would you still need blue iris to feed video to smart tiles? Anyone have experience with there camera and app? Curious.

Can anyone chime in and help direct me?? Thoughts? All this seems a little overwhelming for someone new to surveillance.

Thanks.


(Michael Pasley) #450

how did you get vlc to do this


#451

C:\Program Files (x86)\VideoLAN\VLC>vlc.exe rtsp://user:pass@CAMIP/Path :network-caching=1000 :sout=#transcode{vcodec=mjpg,vb=1600,scale=1,acodec=none}:http{mux=ogg,dst=DESTINATIONIP:PORT/stream/driveway/cam/} :no-sout-rtp-sap :no-sout-standard-sap :sout-keep


(Steve) #452

Not sure if this applies to anyone besides me, but figured I would share what I found out about the Motorola MBP854CONNECT system (video baby monitor). This camera only appears to offer rtsp, so with some help from this, I was able to figure out how to use VLC on one of my linux boxes to capture the RTSP stream and save it out to the same box (via http mpeg stream). Now the camera shows up just fine in Smart Tiles!

(run as my user, non-root)
192.168.1.111 = camera
192.168.1.222 = linux box the vlc command is being run on, this will be the IP that you point smarttiles video stream to, I used port 8084 (e.g. http://192.168.1.222:8084)

vlc -I dummy rtsp://user:pass@192.168.1.111:6667/blinkhd --no-sout-audio --sout '#transcode{vcodec=mjpg}:std{access=http{mime=multipart/x-mixed-replace;boundary=--7b3cc56e5f51db803f790dad720ed50a},mux=mpjpeg,dst=192.168.1.222:8084}'


(Mark De Vane) #453

Am experiencing similar issue.

Background:

  1. STiles dashboards set up and operating properly
  2. have 2 tiles which link to my Hikvision cam for testing.
  1. both of these urls and tiles work fine using - pc (chrome & IE), mac (chrome & Safari), and iphone (chrome)
  2. set up an Amazon Fire tablet and neither of the links work in STiles, so I decided to test the urls in the following browers: Chrome, Silk, and Fully Kiosk Browser – neither links work in any of the tested browsers on FireOS. On Chrome, the URL’s end up being resolved as “unknown” Google searches. I get impression that the browsers cannot handle the user:pw convention.

Any ideas or suggestions on what might be causing the failures only on Fire tablet. The goal (of course) was to use these for cheap wall mounted panels, like everyone else in STiles land.


#454

Has anybody gotten a Panasonic BL-C101A or similar Panasonic cam to work with SmartTiles? If so I would appreciate some hints.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #455

Have you had success on any other Android tablet?

If so, then it would be more than worth the minor trouble to overwrite the “FireOS” ROM with any of a number of good custom ones.


(Mark De Vane) #456

Since my initial post, I was able to resolve at least one problem - no browser on Android will accept the user:password combination, which works fine on all other platforms/browsers. I found that by changing to the Admin user account on camera that I can now get Chrome working, so it seems that user accounts without “admin” roles & privileges are being rejected for some reason. In any case, due (I believe) to my locked/rooted OS release level (v5.1.2), I cannot get “full-screen” operational, so still no-go.

Silk browser (Amazon) also now displays streams and snapshot tiles properly, but the same issue of “no” full-screen.

Fully Kiosk Browser allows full-screen but does not display the streams - either using a direct URL or embedded in a tile.

It would be helpful if we could log setups which are known to work in a STiles Wiki somewhere. Then all new users could have a starting reference point for installation and debugging.

I was hoping to keep the OS as stock as possible, but it now seems I will need to sideload CM in order to get this working. Are most users on 12.1?


(Smuts) #457

Yes. I have CM 12.1 on 2 Fires. It was very easy to flash after rooting. It’s much better than Fire OS. I still have a rooted Fire OS on one Fire just to see. I’m probably going to get rid of it soon.


(Mark De Vane) #458

Asmuts - I see you have a single Fire running FireOS. A few questions:

  1. What version of FireOS is that tablet on?
  2. Have you tried using that one with STiles? If so, have you been able to get internal IP cam streaming AND full screen working successfully? If so, what browser?
  3. on your CM12.1 Fires, what browser are you using for STiles? Any issues with Full Screen and IP CAM streaming on those?

Trying to nail down whether a known-good combination exists for Amazon Fire 5th Gen. Otherwise I need to move on to Android tablets and quit messing around.
Thanks for your input.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #459

Great idea, Mark!

As @JDRoberts has been doing a lot lately, I think it would be mutually beneficial to leverage the offsite “Things That Are Smart” wiki for this purpose. SmartTiles / ActionTiles will periodically copy the information to our Knowledge Base in the future.

The more the Community uses that Wiki for various Topics (not just SmartTiles video, obviously!), then the more and more useful it will become. Maybe someday it will have a paid curator. :expressionless:


So… I have created a pretty simple stub page for “the world” to edit. I will do some high-level maintenance on this page, but I doubt I have the time to transfer all the great knowledge from this thread to the Wiki… perhaps someone can do a few?

Please feel welcome, encouraged (and appreciated) to add other sections to the Page and even-sub Pages. I may reorganize from time to time, and will leave comments for major changes.


(Smuts) #460
  1. 5.3.1
  2. Yes, I can get as close to full screen as you can get. Just the little address bar shows up. (I can’t get a screen shot on the fire right now.)
    I run Chrome. I don’t use camera streaming in ST. I have my HIKVision cameras configured as stop motion cameras in ST. I have the authentication info base64 encoded on the URL.

The HIKVision firmware has an authentication popup for the mjpeg feed that causes issues. I’ve seen this on a Neutab tablet and on a GalaxyS3. It’s not a hardware issue. It’s ST’s inability to handle the popup.

Either way, I wouldn’t use streaming as mjpeg seems to be limited to a single client and I have multiple ST displays.

  1. I use Chrome on the CM tablets. It behaves the same way.

(Mark De Vane) #461

Interesting - I am using the standard un-encoded methodology = user:pw@ip.com. Can you share the URL structure for the base64 approach? perhaps that approach will provide more consistent logins.

If its not a hardware/OS issue, why do we not see the same problem on Mac/PC/idevices? I have no issues with the login from those devices on any browser I have tested to date. Am not disputing your comments, but am scratching my head trying to figure this out. It seems to me that some of the browsers on Android/FireOS can handle the login, and other cannot. I also notice that Chrome seems to fail sometimes. Silk has been the most reliable since I found/fixed the authentication issue earlier. Unfortunately I cannot seem to get either browser into Full-Screen mode, and Fully browser cant deal with the authentication but goes full-screen immediately.


(Smuts) #462

From 9/27 above:

Interesting question. I think I ran into the problem using some shitty neutab tablet running some recent version of Android before I owned any fires. And that was where I was seeing the issue. I just switched to stop motion out of frustration.