SmartThings Community

SmartTiles: Video Camera Compatibility

I’m trying to get a FOSCAM FI9826P working and I’ve tried these various methods with no success. Ideas?

http://(using my internal IP):88/index.htm/videostream.cgi?user=xxxx&pwd=xxxx

http://(using my internal IP):88/videostream.cgi?user=xxxx&pwd=xxxx&resolution=32&rate=0

http://(using my internal IP):88/videostream.asf?user=xxxx&pwd=xxxx&resolution=64&rate=0

This and port forwarding.
http://(using my external IP):/videostream.cgi?user=xxxx&pwd=xxxx&resolution=32&rate=0

I’ve also looked at http://www.ispyconnect.com/sources.aspx and that’s where I was able to get some of these urls listed above.

Is the 9826 one of the H.264 cameras? If it is, did you set the one of the streams to MJPEG?
http://ip_address:port/cgi-bin/CGIProxy.fcgi?usr=admin&pwd=xxx&cmd=setSubStreamFormat&format=1

Then use the substream URL to get the feed…
http://ip_address:port/cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=admin&pwd=xxx

Take note of the difference in the cgi commands.

I’ve been trying to make this work on a 9821 but having no luck. Maybe yours will work.

@eibyer I been using the Foscam 9821 for a while and don’t have a problem with the code that you use. Are you setting the MJpeg for each web browser you are using? I also updating to the latest firmware for the camera.

@llcanada thanks for the confirmation that it works. What firmware version do you have on yours? I’ve been using IE to set the command and got the “0” confirmation that the stream was set. If I try to open the URL in IE via local network, IE prompts me to Save or Download the stream. Really odd. I tested the URL with VLC and it works.

I have the FI9826P and the FI9828P. Both of these are the new H.264 cameras.

This worked for my FI9826P camera.This did not work on my FI9828P camera.
http://ip_address:port/cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=admin&pwd=xxx

When you say MJPEG, I don’t get that option. I show 4 options under SubStream\Stream Type:

  1. HD Mode
  2. Equilibrium Mode
  3. Smooth Mode
  4. User-defined
    ----- this changes the resolution option to 720, VGA, QVGA

System Firmware Version = 1.4.1.10
Application Firmware Version = 2.11.1.119
Plug-In Version = 3.1.0.9

Still trying to figure out my FI9828P camera.

Thoughts?

@llcanada I loaded the URL in Chrome and Firefox and it worked! I must have been tooling around with this for a while that I forget which ones I have tried and which ones I haven’t.

I’m not sure if the FI9828P takes the same command to change one of the streams to mjpeg.

@eibyer I using Firefox and it works. I also try on the Internet Explorer and have no luck since it upgraded to 11. I will try to play around with IE and see if I can get it to work. Thanks for the update.

Can anyone suggest me a good cheap camera that is compatible with SmartTiles and has NAS storage or Local Storage?? :smile:

Hey guys, I can get a working URL for Dropcam, but the video tile is always blank on SmartTiles. I followed the directions perfectly, but I’m getting nowhere! Any thoughts?

Have you tried Chrome?

I heard that Firefox just dropped support for certain type of video streams. I don’t remember the specifics…

Anyone experiencing losing the video stream in Chrome from a Foscam camera? If I use Firefox it’s nice and consistently there, I just don’t like the way Firefox does the full-screen mode.

1 Like

What is the best camera to use with this dashboard? I know, a subjective question, but I have no hardware at this time and since there appears to be limited support for cameras in general with ST, whatever goes well with this dashboard is going to win. :smile:

1 Like

Same question here 20 characters

The answer is easy.

1)Step into your dropcam account with Firefox
2)Enter to the page where you can view your drop cam
3)click on sharing
4)click on make this cam public
5)on firefox click on Tools>Web Developer>web page source code
6)search for the text “uuid=” without quotes
7)copy the next string until &amp without including it
8)now the address you are looking for is https://www.dropcam.com/e/copytext?autoplay=true, where copytext is the uuid.

Hope it can help.

BTW: sorry for my bad english, it’s not my native lenguaje

2 Likes

Thanks, that’s a good way to get the correct URL. I used the the “embed video” code and pasted it into a text editor, then found the entire URL in the embed video code. The problem is Dropcam uses Flash to display the video - so I cannot use it on my iPad which doesn’t support Flash (unless I use a special browser that supports Flash). These browsers aren’t usually free, and you can’t use Kiosk mode to display the SmartTiles. It’s just too kludgy of a solution!

Yes I’m experiencing this too. I use a tenvis (foscam rebranded) and it often kicks out in Chrome. Firefox appears to be fine.

Have you managed to create any smart apps that utilized IPROBOT3 in SmartThings, ive just purchased one and would love to know the possibilities.

I have three Foscam H.64 cameras working with SmartTiles using the MPEG stream. The problem I am having is that after a few minutes (about 15) the live feed stops. The tile keeps an image, but it is no longer a live feed. This is happening both on Chrome for the desktop or Chrome for Android. Any ideas or suggestions? I will try an iPad with Safari next and see if I have the same issue.

Any luck finding the code for the F19821W V2 to stream video. None of these seem to work except for the ones outlined in red for a static snapshot.