SmartTiles v5.8: Deployed to Blue & Green Editions. Release notes, etc. (follow this Topic for updates...)

We will fix this as soon as possible.

Existing SmartTiles installations are to remain working for a while.

1 Like

Excellent, that saves me from having to deploy a new tablet quickly. Thanks @625alex.

Can we assume you will give us some advanced notice when SmartTiles eventually retires?

Yes, of course. We will issue advanced warning.

Thanks in advance for fixing it as mine just stopped working this morning as well.

Thanks for the details Kodak,

I am researching this issue.

We have been doing some server consolidation for efficiency and to keep costs down, so a configuration typo probably slipped in here somewhere.

There’s been a major ActionTiles update this week with a few reported hiccups yesterday, so we’re being pulled in two directions, and ActionTiles gets priority, of course.

I’ll post updates on the SmartTiles Launcher problem to this thread.

####I have identified the root cause of the “ launcher failed” issue and we are in the process of devising and deploying a fix or fixes

The Launcher may work intermittently for several hours while the fixes are being deployed. Sorry for the temporary instability.

1 Like

Thanks for looking at this but you got bigger problems. Any attempts now to go to redirect to a site which has been known to host malware and is blocked by many routers and antivirus software.

Either somebody has tried to hijack your DNS domain or there’s some network issues. Did you maybe make changes to your domain and something didn’t get set right? It shows it was registered last year, expires in 2018 however it shows it was updated today which is likely what took it offline. My guess is it’s your name server NS1.DIGITALOCEAN.COM

Registry Domain ID: D425500000000351007-AGRS
Registrar WHOIS Server:
Registrar URL:
Updated Date: 2017-06-01T19:51:46Z
Creation Date: 2016-05-17T07:25:23Z
Registry Expiry Date: 2018-05-17T07:25:23Z
Registrar Registration Expiration Date:
Registrar: NameSilo, LLC
Registrar IANA ID: 1479
Registrar Abuse Contact Email:
Registrar Abuse Contact Phone:
Domain Status: clientTransferProhibited
Domain Status: serverTransferProhibited
Registry Registrant ID: C17658187-AGRS
Registrant Name: Domain Administrator
Registrant Organization: See
Registrant Street: 1928 E. Highland Ave. Ste F104
Registrant Street: PMB# 255
Registrant City: Phoenix
Registrant State/Province: AZ
Registrant Postal Code: 85016
Registrant Country: US
Registrant Phone: +1.3478717726
Registrant Phone Ext:
Registrant Fax:
Registrant Fax Ext:
Registrant Email:
Registry Admin ID: C17658187-AGRS
Admin Name: Domain Administrator
Admin Organization: See
Admin Street: 1928 E. Highland Ave. Ste F104
Admin Street: PMB# 255
Admin City: Phoenix
Admin State/Province: AZ
Admin Postal Code: 85016
Admin Country: US
Admin Phone: +1.3478717726
Admin Phone Ext:
Admin Fax:
Admin Fax Ext:
Admin Email:
Registry Tech ID: C17658187-AGRS
Tech Name: Domain Administrator
Tech Organization: See
Tech Street: 1928 E. Highland Ave. Ste F104
Tech Street: PMB# 255
Tech City: Phoenix
Tech State/Province: AZ
Tech Postal Code: 85016
Tech Country: US
Tech Phone: +1.3478717726
Tech Phone Ext:
Tech Fax:
Tech Fax Ext:
Tech Email:
DNSSEC: unsigned
URL of the ICANN Whois Inaccuracy Complaint Form:

Last update of WHOIS database: 2017-06-02T01:53:54Z <<<

For more information on Whois status codes, please visit

Access to WHOIS information is provided to assist persons in determining the contents of a domain name registration record in the registry database. The data in this record is provided by The Registry Operator for informational purposes only, and accuracy is not guaranteed. This service is intended only for query-based access. You agree that you will use this data only for lawful purposes and that, under no circumstances will you use this data to: (a) allow, enable, or otherwise support the transmission by e-mail, telephone, or facsimile of mass unsolicited, commercial advertising or solicitations to entities other than the data recipient’s own existing customers; or (b) enable high volume, automated, electronic processes that send queries or data to the systems of Registry Operator, a Registrar, or Afilias except as reasonably necessary to register domain names or modify existing registrations. All rights reserved. Registry Operator reserves the right to modify these terms at any time. By submitting this query, you agree to abide by this policy.

Thanks for the alert. I will look into the redirection error.

The “WHOIS” information you fetched is correct.


The valid is SSL protected (, and the Certificate belongs to “”.

If you get an Invalid Certificate error then DO NOT PROCEED.


Upon further investigation, is not pointing anywhere “malicious”.

  • The DNS record update has simply not propagated yet to our new servers.

  • The old DNS address is thus still in effect until the DNS caches clear. That address: directs to GoDaddy’s hosting “parking”. I hate GoDaddy, and that’s why we have migrated away from them.

  • The new address of “” is propagating: (equivalent to our ActionTiles’s other sites).

PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=63 time=0.791 ms
64 bytes from ( icmp_seq=2 ttl=63 time=0.448 ms
64 bytes from ( icmp_seq=3 ttl=63 time=0.455 ms

As mentioned in my earlier post, propagation of the address update will take time, depending on your name-resolution provider (i.e., usually your ISP, but some folks use Google:, etc.).

For example, I have several servers, VPNs, etc., and get the correct address from “”, as well as from “Google Public DNS”:


Non-authoritative answer:

$ nslookup
Non-authoritative answer:


The old address may be cached in your router: You should reboot your router to possibly expedite its nameserver refresh.


If you are being directed to “dnsrsearch”, that indicates you have already have a hijacked / virus infected browser or nasty ISP / DND name-service provider that was NOT caused by SmartTiles. This hijack picks up any “dead” web access attempt and then redirects it.

#At no time has “” been directing users to an “unsafe” or “malicious” website.

I repeat that is now SSL protected with a registered Domain Validation Certificate from

The Certificate is domain validated to “”.

If you get an “Invalid Certificate Error” then DO NOT PROCEED.

  • You should try rebooting your router.
  • Otherwise, you must wait until for the correct server address for has been propagated to your name servers (takes up to 24 hours).
  • You may also need to clear your browser’s cache. You can test this by using an incognito session.

I just confirmed that this solution above worked for me.

i.e., If your “” Launcher URL is not working, please power off and power on your Router. It is likely to help. You may need to follow this by clearing your browser’s cache.

To test your current name server’s resolution of; in Windows (and many other OS) you can run “nslookup” on the cmd line or shell:

$ nslookup

The address above is the only correct one ( at this time.

Lol it’s not my browser but I appreciate the concern. It’s Spectrum aka Roadrunner. When it can’t find a DNS entry it redirects and Asus routers then pop up with a warning message about the dnsrsearch site.

DNS takes some time to propagate as you say. I added your IP to my hostfile and I’ll see if that is working until the DNS caches are flushed.

1 Like

Terry I think I found one of the problems. The URL link that the “Smartapp” spits out is http. When you mentioned the new site is using https a light bulb went off and I modified the URL and it’s working.

On the same system though if I try the I’m redirected to dnsrsearch.

I appreciate you taking a look at this since some of us were concerned that smarttiles was cut off without warning to force actiontiles but I’m glad that isn’t the case. It was not my intention to give the impression smartiles was serving malware either, just that it was triggering my own malware defenses because of the re-direct which is likely Spectrum cable companies genius idea.

I went back into the smarthings app, smarttiles plugin and “Get Launcher URL” section and it is still directing to an http url instead of https. The smartapp may need to be updated to reflect the new URL.

I’ll write a quick update on the reddit thread and point people to the https url. Thanks again.

1 Like

Unfortunately, we are not permitted to update the SmartApp.

Instead, the server for “http://SmartTiles.mewill be is configured to redirect to “” automatically, and works fine unless you have a nasty DNS name service provider.

Between us I’d be using if it didn’t cause me problems with my VPN. :wink: I updated the reddit thread and thanks again.


Anyone else have issues with smarttiles video streams recently? Mine had been working fine for my Amcrest 1080P cameras until yesterday. It now no longer shows the video stream feed that is configured in /video streams/generic mjpeg video streams/. I know the camera is fine as it still works in my resync link url I had previously set up in /more tiles/links to other websites/ to resync the feed to restart it if there was a power outage. The same url configured in mjpeg is still working on my Tuxedo Touch keypad and I have not upgraded my Amcrest 1080P’s firmware since I did that a couple months ago and had to roll back to 2.420.AC00.16.R because of the auth issue in the lastest version.

Do you know if the browser has been updated?

I believe it updated to Fully Kiosk Browser version 1.18 recently on my android 5.0 tablet.

I downgraded to older versions of fully kiosk browser to test and still no luck so doesn’t seem to be browser. Tried changing stuff in Amcrest DTH and still same. Tried configuring the mjpeg stream in a separate smarttiles dashboard and still no video either.

###What format is the “stream URL”, please?

Google / Chrome (and underlying chrome web view in Fully, very likely) has just started blocking URLs of the form: http://user:password@address; this is a huge deal, and there is no workaround that we are aware of yet.

NB: The code / SmartApp of SmartTiles hasn’t changed in over a year.