SmartTiles v5.8: Deployed to Blue & Green Editions. Release notes, etc. (follow this Topic for updates...)

What are you using for a virtual thermostat? I want one. :slight_smile:

I’m working on a custom setup which is a really early version. It’s working stable at home though.

You can see the SmartApp here https://github.com/anderssv/smartthings-code/blob/master/smartapps/smartthings-f12-no/heating-control.src/heating-control.groovy . You can test if you want to, but remember to install the thermostat device handler from the same repo. :slight_smile:

I also recently saw this setup (but I think it requires real thermostat devices), that I’ve been wanting to test. [BETA RELEASE] Multi-feature Programmable Thermostat SmartApp

Let me know if you test mine and have any quesitons, but do it in PM or a new thread so we don’t hijack this one. :slight_smile:

1 Like

Any updates on release date?

It has gone very quiet after the tease 18 days ago.

That is why I am asking, how long do we have to wait?

Please follow this thread for ActionTiles release announcement:

4 Likes

Has anyone figured a way to display a .SWF Flash movie into one of the SmartTiles video streams? Specifically, something like: http://www.wunderground.com/swf/pws_mini_rf_nc.swf?station=KCAMULFO2&freq=&units=english&lang=EN

SmartTiles doesn’t really have a way of dealing with plug-ins such as Flash. The HTML tag to support video is pretty bare-bones. We’re trying to fancy-it-up in future versions of ActionTiles, but it will be incremental and the road-map has not been laid out.

###Important Alert added to the SmartTiles Blog:

1 Like

I just setup smarttiles, and it’s really pretty cool. Only problem is the clock tile shows the wrong timezone. My smartthings hub is set right, so the events log is ok, but I can’t figure out how to tell smarttimes to change the tile time zone.

Any ideas?

The Clock Tile currently only shows the time of the clock on your browsing device (Tablet, PC, etc.).

Make sure your system timezone is set correctly?

Odd, I was traveling internationally a few days ago, but I’ve been back in
the states for a few days. If I view the dashboard on my laptop the time
is right, it’s bad from my phone browser. I’m not why. Oh well.

Not sure why either… but; may be worth rebooting your phone now that you’re back in your home Timezone?

@tgauchat From the issue from the css topic. Here is the screen shot of the error I get with the preview option and/or the “get launcher” option.

I get this same error on the current link on any browser with the link I was using before.

1 Like

Exactly the same as @Controlbreak. I tried two different accounts on two different devices Android 5.0.2 and 6.0. I also tried uninstalling the app and reinstalling.

I deleted a dashboard and created a new one. That is when I discovered the issue. I have five dashboards installed.

Can you describe this part in extreme detail please?

SmartTiles does not use any sort of “token” when accessed via the Launcher URL.

So I need to know exactly what is different in the behavior you now observe compared to the past, when using an existing previously functional Launcher URL.


I’ll be honest here guys… We have not changed anything - not a single byte - of SmartTiles since the release of v5.8 over a year ago.

Whatever problem you are encountering is likely due to a change on the SmartThings platform. I have not been able to reproduce it given the descriptions so far. The problem would be conceivably related to the ActionTiles, Amazon Echo, Google Home, etc. outage experienced by SmartThings on past Friday evening.

Perhaps @slagle has some ideas?

While we still are “officially” a few days away from the announced “April 15th” date for withdrawal of SmartTiles support, the universe appears to want to rush that along. I’m not inclined to fight it; we simply don’t have the resources.

Understood. Just wanted to see if you had seen it before.

Details(again only if something jumps out at you, for me to do, I already have actiontiles installed):
I would get a url from preview/launcher.
I would take this url and get it to an old fire (very painful) then I would be required to sign in to ST EDI web.
I would see the dashboard I saw under the preview.
All is well and wife is happy. :wink:

Now I get the screen shot you saw with no login prompt. I get this in the ST app and I get this same error in chrome, Firefox, IE, and whatever the old version of a fire uses.
I agree that this is a change in ST that will not/probably should not get any attention.
Thank you for the support you do provide. This is what prompted me to spend money with AT.

1 Like

The, ummm, “operations” that are executed to bring up a dashboard are very different in these two situations:

  1. Previewing the dashboard in “web view” from within the SmartThings SmartApps preferences pages.

  2. vs Opening the Launcher URL in any external normal browser.

For root cause analysis, it is important to know with 100% confirmation whether or not these two different activities result in the exact same mis-behavior.

And… Determine: Is this the same for everyone experiencing the issue, and how widespread is the issue… And what is the difference in environment or configuration between those who have the problem and those who do not: shard? edition? (blue vs green), etc etc.

Very very few reports so far. Perhaps a good sign that this is isolated to a particular environmental or SmartThings Account condition(s)??

Na02 shard, 5.8 +50 green, Multiple browsers. Android 7.0.1 running ST app 2.3.1 build 211001.
Same error for both situation 1 and 2. Above screen shot is situation one. Below is 2

No… You misunderstand.

By scenario #2, I mean: using an existing Launcher URLnot fetching a NEW ONE from inside the SmartThings App!!!

What happens with AN EXISTING, previously WORKING, LAUNCHER URL COMPLETELY OUTSIDE THE SMARTTHINGS APP?

PS: The frustration isn’t aimed at you … just nobody has given me the above correct specific diagnostic yet.