SmartTiles v5.8: Deployed to Blue & Green Editions. Release notes, etc. (follow this Topic for updates...)

FYI: We just received another confirmation that ESET firewall software definitely causes the rendering symptoms described above… at least on PCs.

Of course, this isn’t the only possible cause, but it does explain several occurrences now.

Same issue here. Running on Safari for iPad and Spacious Browser on Wink Relay/Android. I haven’t made any changes to my firewall since it was last working properly. I figured it was related to the token issue as a logout and back in to generally gets it working again… only to break again after 15 minutes or so. It’s a shame as SmartTiles was previously the only part of my SmartThings solution that I could always count on working.

I reset my Wink Relays and installed the SmartThings app as default instead. It’s not pretty, and lacks the dashboard/tiles view that I spent so much time customizing for every room, but it gets the job done.

If it helps you correlate the issue to any changes that might have been made in the app or SmartThings, my SmartTiles setup worked through Sept 25th when I left on a business trip. On my return Sept 28th… I found all my panels showing the !@#? cloud error and malformatted as described by others.

1 Like

Thanks for the data…

We have not changed SmartTiles in months and so far have not been able to replicate this issue personally, but we’ll try to escalate to @slagle and @jody.albritton to see if there’s any clues on their Cloud.

Meanwhile we are doubling up our efforts on getting V6 released. Maybe we’ll cut a few features and work on them post release…

Just for the record I am having the same cloud picture error. I have tried 2 android devices, 2 ios and same issue. It all started about 2 weeks ago.

  • Do you know what SmartThings “shard” you are on?

  • Are the devices continuously active? Do you have to “login” again after the error? Is there any time pattern to the appearance of the error (i.e., time of day, or duration between errors)?

  • Have you experienced the same problem using a desktop computer?

  • Any patterns at all might start to indicate the root cause. Are all Dashboards affected if you are running multiple Dashboards? Are some larger (more Tiles) than others? Newer Dashboards vs. older Dashboards?

@625alex and I are very concerned, but with the current version of SmartTiles (v5.8), we have very little control over the serving of Dashboards … the pages are served from the SmartThings Cloud via the instances of SmartTiles installed in your Accounts.

The complete overhaul of SmartTiles (“V6”) moves the serving of web pages to non-SmartThings clouds (and various other architectural changes that are more robust and resilient and offer better diagnostics).

If we spend too much time trying to diagnose this problem in V5, then that will delay V6, which is really the worst possible outcome we need to avoid at all costs, especially with V6 proceeding solidly along our internal estimated schedule (still some a few critical elements of V6 are not yet complete and they have enough effort variance that we still won’t give out an estimated release date).

FWIW I am on na02-useast1 and have had no issues with the tiles.

1 Like

I have no idea about "shard’ nor where to find the info. I have not tried it on a laptop but i will. when I touched the screen I got the message
Full Authentication Required
Then more of the same about 0auth. Thinking it might be by hub/router/firewall I connected via LTE and had the same problem.
All this just started a few weeks ago so smartThings or Tiles changed something. If I could find something that worked a lot like tiles I would change but I haven’t. I like it and wish someone would fix it.

Your “shard” is shown in the Launcher URL for your Dashboard that you copy/paste from inside SmartTiles preferences configuration.

It’s like NA01, NA02, EU01…

The OAuth error occurs if you are not using the Launcher URL, perhaps?

SmartTiles hasn’t been updated or changed in any way whatsoever in months (since release v5.8).

The next version is an entire rewrite which should greatly avoid these issues you are experiencing.

I’m relatively new to SmartThings and SmartTiles. I figured out how to setup a wall-mounted tablet with a basic dashboard running. I am wondering is there a way to open an android app using a link tile? I tried searching the previous threads and was only able to find a method of doing this with iOS, using appname://. I tried this with android but cannot get it to work.

That method works with some Android Apps. It is up to the App developer to have included the proper “browser intent” in their packages.

Unfortunately, I am trying to open my Flir Cloud App to access all my security cameras and it doesn’t seem they did. I don’t suppose there is another way of accomplishing this is there? I tried the tasker url plugin but it doesn’t seem to work either. Also, does anyone know if there are any plans to include Google Calendar info? I saw someone asking about this in another thread but the only response I saw is that it could be possible in the future.

Once V6 has launched anything is possible, but it will be a take-a-number situation. The list of feature requests are a mile long, so we’ll have to prioritize by how much and how many customers benefit. We’ll probably have an open feedback forum to help customers submit, discuss, refine and vote.

ok. thanks. look forward to it.

What are you looking to do with Google calendar? I know it doesn’t interface directly with smart tiles. You can to it through Tasker.

I was just hoping for a tile that would show upcoming events.

So I tested using my browser on two laptops. No problems, works consistently. This would tell me the problem of locking leaving a cloud on the screen on the tablets is not a firewall issue nor my router config.

I don’t know what is common to Android and IOS that isn’t in a PC’s browser but I hope this helps someone figure it out.

If I had to guess I think it has to do with one of the SmartThings updates. It seems they did updates about the same time this all started to go haywire.

Really looking forward to V6 as I have all but stopped using SmartTiles due to the token removal… and I miss it. I get the security concern but just not worth the extra 5 seconds to bring up the page when needing to flip a quick switch. Hope it comes out soon :), thanks for the hard work.

1 Like

My Event History stopped working. I just get:

{“error”:true,“type”:“java.lang.RuntimeException”,“message”:“An unexpected error occurred.”}

Is there a way to fix this? Thanks!