SmartTiles Dashboard v5.5: Added UK 🇬🇧, 5 × Dashboards, and more! Nov 6, 2015

SmartTiles is down for me right now. Won’t turn off a light.

I’m curious to see your Trace level of Live Logging for this, as I’m not experiencing problems…

Support@SmartTiles.click

@tgauchat In addition to the message I sent to you, I went back and tried the live logging a few times and still nothing shows? In a search of the forum, some state that using SmartTiles and LiveLogging won’t work (I dunno)?

Anyway, I just tried to use the IDE again and instead of the usual login I got this text instead:

"It works !

If you’re seeing this page via a web browser, it means you’ve setup Tomcat successfully. Congratulations!

This is the default Tomcat home page. It can be found on the local filesystem at: /var/lib/tomcat7/webapps/ROOT/index.html

Tomcat7 veterans might be pleased to learn that this system instance of Tomcat is installed with CATALINA_HOME in /usr/share/tomcat7 and CATALINA_BASE in /var/lib/tomcat7, following the rules from /usr/share/doc/tomcat7-common/RUNNING.txt.gz.

You might consider installing the following packages, if you haven’t already done so:

tomcat7-docs: This package installs a web application that allows to browse the Tomcat 7 documentation locally. Once installed, you can access it by clicking here.

tomcat7-examples: This package installs a web application that allows to access the Tomcat 7 Servlet and JSP examples. Once installed, you can access it by clicking here.

tomcat7-admin: This package installs two web applications that can help managing this Tomcat instance. Once installed, you can access the manager webapp and the host-manager webapp.

NOTE: For security reasons, using the manager webapp is restricted to users with role “manager-gui”. The host-manager webapp is restricted to users with role “admin-gui”. Users are defined in /etc/tomcat7/tomcat-users.xml."

Please run SmartTiles and Live Logging on two different computers or two different “incognito” or “private browsing” windows to avoid authentication clash between SmartTiles’s token and the API/logs session.

1 Like

Got it, thanks. I was using my cell phone with SmartTiles and my desktop PC for the IDE.

The Tomcat page you see is a messy anomaly that SmartThings ought to investigate (take note, perhaps, @jody.albritton?).

It’s usually caused by a previous login Session of some sort. If you can’t get to the Live Logging page, close out all the browser windows and try logging in again.

Dropped the logs to you at Support@SmartTiles.click.

It appears that in the cases where this isn’t working the event is not being delivered to the light in question.

My logs show one case where it doesn’t work for a specific switch, and one case where it does. I think I found the common denominator just now! Anything for Z-wave GE/Jasco switches is NOT working. The only lights/switches I can control from SmartTiles are virtual switches or my Zigbee bulbs.

Maybe this will help you debug it, but it’s likely a device type/platform issue. Note that all of my GE/Jasco switches are using the standard device type - nothing custom.

1 Like

In my case, a random but specific repeatable Thing or few are failing… One is a SmartShield project that’s worked flawlessly for… Well, since I built it months ago and use daily.

Thanks again for the help tonight @tgauchat. All is working now with SmartTiles, apparently the backend “glitch” was corrected which solved the issue for me. Fingers crossed it doesn’t “glitch” again anytime soon.

…SmartTiles, the best thing about ST.

1 Like

I had exactly the same problem last night with SmartTiles. To be fair I thought it was something I had done given I’m playing with Rule Machine and Initial State at the same time.

It happened at exactly the same time as I built the Initial State SmartApp (the direct version) which actually works a dream.

Interestingly I could control the Hue lights but not the normal SmartThings switches.

Pleased to report everything is working perfect now.

1 Like

I have a problem I can’t figure out. I have two iPhones set up as presence sensors. Both show present in ST app but in Smart Tiles one is dark blue the other is grayed. Picture below. I have tried refresh no luck. Can someone give me some guidance?

This is an issue with ST data replication between servers. Your phone is showing state from one server, but SmartTiles is showing a value from another. This issue became more apparent in the recent weeks. This usually goes away on it’s own and there is nothing you can do about it.

Current implementation of SmartTiles does not store or cache any information and only shows what ST think is the current state of devices.

Yes I have noticed where status of switches etc, not shown proper state but usually a refresh fixes this, but not the presence. I guess I shall wait and see if it shows proper status. Thanks.

From my experience, you won’t see the correct state until your actual device changes the state again. So check after your presence device leaves.

Will do. And hope it works.

@625alex … Have we opened a SmartThings Support Ticket for this problem yet?

I don’t know how widespread this data inconsistency is, but it certainly impedes the quality of SmartTiles. If we can confirm and come up with somewhat reproducible scenarios, we should contact Support and escalate to the Developer Advocates.

We can also then recommend users contact SmartThings Support to emphasize the extent of the problem.


@joelw135: Let me know if the problem is fairly constant, or comes and goes. If it is somewhat consistently wrong, then your Live Logging data could be helpful and we can escalate this together.

There’s no harm in opening a ticket, but I don’t have high hopes for resolution. It’s very difficult to reproduce.

Thanks… If myself or a user can get some sort of reproducible scenario with Live Logging data to support the details, then I’ll open a ticket and follow-up with Dev Advocates.

This problem has got to be affecting other services too; though … IFTTT, for example, is much less complicated than SmartTiles because IFTTT only checks 1 SmartThings condition at a time!

But what about Rule Machine, SmartRules, etc, etc. – Rules can’t work correctly if these SmartApps don’t have consistent data across different Things. If a rule says “if Mom and Dad are home …”, then @joelw135 would (or could) experience the same problem that is visually represented in his SmartTiles instance.

1 Like

I don’t really get the purpose of SmartTiles I guess… a Windows 10-esque dashboard that shows “Things”?
I guess I just don’t really understand the purpose of it or why it is useful.

And it’s in the browser, but why?

Just curious… not trying to be insulting I guess it just doesn’t seem to do much more than the mobile app does…?

One page access to all you main devices. The ST app requires a lot of scrolling or drilling down to get somewhere. At least 3 actions to get to most of my devices, list I can’t order and devices I don’t need to see. With this you can just pull up a web page and what you need is there.

Also it’s great for using a tablet as a interface for everyone including the less tech savvy in the house.

3 Likes