SmartTiles Dashboard v5.5: Added UK 🇬🇧, 5 × Dashboards, and more! Nov 6, 2015

you can try Rule Machine instead of Notify Me When. You can set it up to do the same thing as Notify Me When.

Thanks, I’ve run into a more serious problem though. Well, one serious and one irritating.

The irritating one is that Hive doesn’t support a Boost text command, I can only turn heating on/off and set temperature. So to emulate a Boost I’d need to send a command (“HEAT AUTO 22”) and then wait an hour before sending “HEAT AUTO” to put it back to schedule. This timeout seems to be an issue with Notify Me When, I’ll go and check Rules Machine

The dealbreaker though is that Hive will only accept a +44 UK number to go on it’s whitelist of numbers allowed to control the heating. SmartThings SMS messages come from a +1 202 number. I’ve reached out to Hive support to see if this can be overriden, I suspect my answer will be something relevant to the fact they’re just about to launch their own ST style devices (bulbs, sockets, motion sensors, door sensors) and they’d rather not provide cross-platform compatibility.

When you put your number in make sure you put +44 and remove the leading 0. The text will come from a US number so you need the county code.

Ah, just seen your latest comment. Maybe try linking with IFTTT to send a text, not sure if this comes from a UK number though.

Yeah, sorry I neglected to say I finally figured out that one! Sometimes I forget there’s a big wide world out there… Thanks though :slight_smile:

Right. So, latest state of play is:

Binned the simulated button, went for a switch.
Used IFTTT (since it works with switches, not buttons) to send a HEAT AUTO 22 message from my phone to Hive when turned on, and HEAT AUTO message from my phone when turned off. So I’m using IFTTT to generate the texts from my own phone, hence it’s a UK number, and they’re quite happy with that.

So the remaining issue is to work out how to toggle a switch back off when it’s been on for 60 minutes. I saw someone mention something about an energy SmartApp so I’ll go hunt that out.

Thanks all so far for help with this!

1 Like

Great that you’re finding help with this Chris!
Would you do us big favor and spin off a new Topic for this, though, as it is no longer SmartTiles specific?

This type of integration of SMS with IFTTT via Virtual Switches (etc!) will be useful to a lot of folks.

This appears to be a SmartThings bug. New Topic(s) created:

I just tried installing smart tiles and I get this same message. The only unofficial device type I’m running is for Nest. I removed that device from Smart Tiles but still get the same message.

Thanks for letting us know. @625alex and I have reports of this error from a few users, but not very many, so we are having difficulty pinning it down.

You can send a note, please, to: so we don’t clutter the Topic with personal debugging steps.

If you know how to use SmartThings API/IDE Live Logging some of that output may give you or us vital clues. Start Live Logging just prior to the actions that cause the error message… etc. Similarly, and Firebug or Chrome Debugger output can be helpful.

But in the meantime, feel welcome to experiment by using one of the additional child dashboards with zero device tiles (i.e., just the default tiles), and/or no temperature based tiles, no weather tile, … i.e., a few simple combinations to see if you find that any particular ones work and which ones don’t.


Is there a way to have SmartTiles actually “control” instead of just “View state of things” my Linear GD00Z-4 garage door opener? I have just installed SmartTiles and created my first dashboard, but I cannot seem to find my Garage Door under the “Control things” part of the app.

Good job on the rest of it though!!!

Thanks for your help.

1 Like

check contact sensors under the Control Things…

Thanks for your response. However, on my app, I only see Locks, Music Players and Cameras (Image Capture) under “Control things…”. Contact Sensors (and thus my GD00Z) only show up under “View state of things…” which does not seem to give me the ability to control it.

I have just installed the SmartTiles (Connect) app today. Is there perhaps a different version I need?


Oh! Sorry… actually go up and look under Control Lights… Momentary Switches.

Sorry about that, I should learn to not trust my memory, lol

For some reason my garage door device does not show up under “Momentary Switches”. My GD00Z-4 is installed and connected as a “Z-Wave Garage Door Opener” type.

In looking into this a little deeper, I compared the settings in the SmartTiles app for my configured dashboard to the settings in one of my rules which are able to control (open or close) my garage door. The rule which can control my door has implemented the “capability.garageDoorControl” which, it seems, the SmartTile app did not implement and therefor is not able to control my garage door. I guess I am out of luck at the moment.

Hmm. did you also check the regular Switches category under Lights?

Yes, I checked them all. My Garage Door Opener only shows up under the “Contact Sensors”.

Thanks for your help.

There are a lot of non-too-difficult workarounds. I haven’t checked if the Device Type Handler (and/or SmartApps) you are using has source code available; if so, a few lines can be added to add “door” or “switch” capability and have that call the available methods to open/close the door, etc…

Similarly, you could add a Virtual Switch and it’s pretty easy to link it to the available open/close, etc., method of the real Device.

I will look into your suggestions.

Thanks very much!!

1 Like

@carlovn Try this modified device type that makes the garage door act like a switch.