SmartTiles Dashboard v5.5: Added UK 🇬🇧, 5 × Dashboards, and more! Nov 6, 2015

Hmmm… SmartTiles depends on SmartThings’s “SmartApp” processing to be all in sync and such; so perhaps something went out of wack.

Try going into the native App, open the SmartTiles under your installed SmartApps and then open the child-Dashboard configuration for the malfunctioning dashboard. You could turn on a higher level of Live Logging, but it may be sufficient to just press “DONE” in order to restart the SmartApp.

If it still doesn’t work, then, indeed, please send us some Live Logging output to: Support@SmartTiles.click

  • Log Level setting (for diagnostic output to IDE Live Logging US or UK added under “Preferences” (defaults to “Error” only).

Thanks for the speedy help.

I did as stated above, but unfortunately nothing changed. I also tried the live logging, but nothing appears in the IDE live log page for me? To be clear, I set the log level to debug, used SmartTiles then checked the live log page. As I aven’t used live logging before, perhaps I’ve got this part wrong.

Also tried a cold reboot of the hub thinking maybe there’s a disconnect between local vs. cloud resources, but again nothing changed?

SmartTiles is even getting errors with our unchanged web installer right now… And I hear of various other development environment problems.

Perhaps a temporary hiccup, but I’ll keep you posted.

Any clues as to what’s going on with the Platform at the moment @slagle @jody.albritton? Thanks…

Thanks very much for the help.

1 Like

I noticed that the IDE has “Device Handlers” now instead of “Device Types” so something is in the process of being changed…

Gawddangit!

This same visible change occurred a few weeks ago and reversed just as quickly.

The continued unannounced Platform changes (without any pre-release notes of any level of detail!) is extremely unprofessional and, frankly, makes developers like @625alex and myself look like amateurs because of the side effects.

##Update
There is at least one known issue causing some problems with 3rd-Party services…

1 Like

I personally wouldn’t want all that other non-HA stuff cluttering up my tiles. It is very easy to switch to another app.

1 Like

I agree here. The calendar would either be very small, or need to take up a 3x3 matrix of tiles, minimal, unless you only wanted that day’s list.

I think those who want it would be better off just adding it as a link with your Private Address available in Google Calendar.

The idea is to add universal items.

The current incarnation of SmartTiles (“v5”) is not likely to get any new features, unless we get really bored and need a distraction from V6 development.

For V6; @625alex are I are committed to the MVP (Minimum Viable Product) paradigm, because it’s the only way we’re going to be able to get the darn thing released before 2017!

For now MVP is all about the reworking the backend for efficiency, security, and optimal compliance with SmartThings’s requirements and guidelines. From a user perspective, it means we want to delivery with as much of the current features, and look-and-feel functionality as possible.

SmartTiles philosophy for the foreseeable future is that it is really based on SmartThings’s capabilities, primarily. In other words, when we have to prioritize features, something like Google Calendar integration is actually more likely to happen if SmartThings does it first. It’s just a strategic path that we may eventually deviate from.

Supporting “plug-in Tiles” of a wide variety is a great concept and we’re bound to experiment with it when we’re in a position to (a) afford the time and effort, and (b) have a feedback mechanism to test this against a large portion of the user base – far more than those who we can reach in this Community alone, unfortunately.

1 Like

I’d just like SmartTiles to work again here. Sigh. :confused:

1 Like

If nothing appears on the Live Logging page in the API/IDE for your region (NB: it is US or UK specific!) and Account, then something bigger is wrong.

Perhaps drop me a line at: Support@SmartTiles.click so we can double check your Live Logging settings and see what’s going on.

Okay, will send a note to you; I really appreciate the help.

Shawn

1 Like

@tgauchat - I’ll follow this thread to see what you all come up with. I’m having a similar, but not completely the same, problem. Most of my light switches (both on/off & dimmer) tiles work to show status, and also for control.

However, I have two that I’ve identified so far that are seeing the behavior @ShawnInPaso reports - they correctly report status, but any attempts at control (on/off/dimmer) basically do nothing.

Thanks.

There’s a wider issue with SmartThings going on now. Hopefully when the issue is corrected, SmartTiles will return to normal.

1 Like

There’s always a wider issue going on in SmartThings. :frowning:

I had to chuckle and resist sending them back a nasty gram when I got the ‘please signup for our monthly paid monitoring service’ email.

Shyeah, right… give me local processing of things like Rule Machine, and a consistent and stable platform. Until that that time, the only time I want to hear from SmartThings is when they can actually say ‘things are stable for longer than 1 day.’

3 Likes

An isolated issue with certain specific Things is interesting, particularly if limited to SmartTiles. Are they the same type / brand of Device?

I would be curious to see Live Logging output (at Debug or Trace level) related to attempts to activate these Tiles…

Let me see what I can do - it might be a day or so, as I’m tied up with some other things and only found this tonight while trying to control things through SmartTiles…

Thanks.

1 Like

SmartTiles is down for me right now. Won’t turn off a light.

I’m curious to see your Trace level of Live Logging for this, as I’m not experiencing problems…

Support@SmartTiles.click

@tgauchat In addition to the message I sent to you, I went back and tried the live logging a few times and still nothing shows? In a search of the forum, some state that using SmartTiles and LiveLogging won’t work (I dunno)?

Anyway, I just tried to use the IDE again and instead of the usual login I got this text instead:

"It works !

If you’re seeing this page via a web browser, it means you’ve setup Tomcat successfully. Congratulations!

This is the default Tomcat home page. It can be found on the local filesystem at: /var/lib/tomcat7/webapps/ROOT/index.html

Tomcat7 veterans might be pleased to learn that this system instance of Tomcat is installed with CATALINA_HOME in /usr/share/tomcat7 and CATALINA_BASE in /var/lib/tomcat7, following the rules from /usr/share/doc/tomcat7-common/RUNNING.txt.gz.

You might consider installing the following packages, if you haven’t already done so:

tomcat7-docs: This package installs a web application that allows to browse the Tomcat 7 documentation locally. Once installed, you can access it by clicking here.

tomcat7-examples: This package installs a web application that allows to access the Tomcat 7 Servlet and JSP examples. Once installed, you can access it by clicking here.

tomcat7-admin: This package installs two web applications that can help managing this Tomcat instance. Once installed, you can access the manager webapp and the host-manager webapp.

NOTE: For security reasons, using the manager webapp is restricted to users with role “manager-gui”. The host-manager webapp is restricted to users with role “admin-gui”. Users are defined in /etc/tomcat7/tomcat-users.xml."