Smartthings work from the assistant on my phone but not from the Home device - fix

googlehome

(Jhinchman189) #1

Hello,
I found this fix after hours of fustration with Google home. Thanks sladflob! I was having the same trouble with an ecobee.

drbobrinkman May 30
I have a weird problem with the Google Home integration that the Google Home support team has not been able to help me with.

I just recently (May 23, 2017) tried to setup Google Assistant and Google Home to control my LIFX lights. I opened the Google Home app in Android, and setup the lights following the instructions. Afterward I’m able to control my lights from my phone, but NOT via Google Home.

If I tell Google Home “Hey Google, turn on the lights” the device responds that “It looks like those lights haven’t been setup yet. Go to home control to add lights.” If I say the same phrase to Google Assistant on my phone then everything works correctly, and the lights turn on.

I see the lights as been added in the Google Home app.

Right now I’m gathering info: Has anyone else experienced this problem? I’m guessing that something is going wrong with the setup process … perhaps the Actions that are being deployed to Google Assistant on my phone aren’t also being deployed to Google Home as they ought to be

sladflob26d1
I just picked up a Google Home today and am having exactly the same problem. My LIFX lights work from the assistant on my phone but not from the Home device. I’ve tried unlinking and relinking my LIFX account several times but the problem prevails. Anyone got any other ideas?

edit: Just wondering if the others having the problem are using GSuite accounts? I am, and am finding that there are a few services that don’t work with them. I don’t know if home automation is one of them but if it is I’ll be quite annoyed.

sladflob25d
Replying to my own post here but I got it working and thought I’d summarise here in case it’s of help to anyone else.

I had two users connected to my Google Home but was only trying to add the LIFX bulbs to one of them (mine). I got my partner to add the LIFX bulbs to her devices and it magically started working for both of us. Her account was the one used to set up the Home in the first place so not sure if that’s significant. Anyway, it’s working now which is cool.


(Daniel O'Meara) #2

Wow! This worked for me too. Seems crazy. And in my case my own account was the “primary” but I still needed to add all the Smart Things devices to my wife’s linked account before Home would work. Thanks sladflob for posting!!


#3

Same drama here. Via Google Assistant on my phone ‘Turn lights off’ works. Via Google Home ‘Turn lights off’ didn’t. I can see via the ‘My Activity’ that GH is correctly identifying it. So I hit up GH support/live chat. They too suggested it may have been the way I setup GH. My problem was, I setup GH using my account as the primary, but apparently, because it didn’t actually hear my voice first, that’s where the problem was.

So I factory reset the device, set it up with my account AND made sure my voice was the first it heard. Now, no dramas at all. My account is the only one linked, yet all of my family can do whatever they want with the lights.