" Smartthings won't run unless you update Google Play"

Okay I may be in the minority with an Amazon Fire phone, but I know a lot of people were stocking up on the Kindle fire tabs for <$50 and sideloading ST from 1market,
I opened ST on my phone this morning as was greeted with grayed out screen and red banner
** " Smartthings won’t run unless you update Google Play" **
I attempted to open it on my old phones and tablets and got the same notification. So as of right now the only devices I can use to access ST are my Samsung Tab 4 and the daughter’s Tab 3 . My old Droids, Dell streak and Motorola Xoom are dead in the water .
A warning that you were breaking/ making the app so it will only work on current gen Android devices , killing it on Amazon devices would have been a nice heads up. I guess I’m lucky that I already rooted the $35 kindles to install CM12 with Google services. However I have no interest in rooting the phones we use everyday just so we can use ST. There is no way to even get the drivers to update Google on our older devices like the Bionics, Xoom and Streak.

Could be some issue with Google Play Services though… I don’t see why they would tie the app to the version of the Play (I assume Store) itself.

Except that I have never had Google play services on Kindle HDX or Fire phones ,and it was never required to use ST app. Now obviously it is required.


Could be some change that was introduced that made that a requirement.

I know that Google is catching a lot of flak for moving a lot of stuff out of AOSP, and the forks that don’t have access to the “Google Apps” like the Kindle were always a concern, but I wasn’t aware that ST had made this jump.

1 Like

Didn’t know this either. I do have an Amazon phone and have google plays service without rooting the phone. I think you need to just sideload 4 Google apps. ST still working on my phone so far.

Have you tried side-loading Google Play Services? You don’t need root for that - just a trustworthy source for the apk and “unknown sources” enabled in device settings.

I don’t know if it’s always been this way, but I believe the reason it’s required now is because ST push notifications depend upon GCM, which is part of Google Play Services.


apkmirror is your friend :slight_smile:

1 Like

I tried that way back when I first got our first Firephone, but it kept crashing so I uninstalled them. I know that somebody has probably updated it so it is stable ,but just never bothered looking again. After 18 months I’m tired of the phone anyways LOL.
I just haven’t found one I want to waste the $$$ on to replace them. LOL

No push notifications on Amazon OS is why I just set everything for SMS notifications :slight_smile:

Have to mention as usual… SmartTiles should still work, as it runs in the browser.

1 Like

Yes I know. I already installed Smarttiles as the ONLY bookmark in the pile of $35 fires the mailman brought me yesterday.
Smartiles is great on tablets, but hard to scroll on little old phones. I did notice that there was a new/updated smarttiles . Just didn’t investigate it yet.

1 Like

Definitely let me know more… We did just fix a quirk that caused “text / object selection” instead of scrolling when dragging across Tiles. Not sure if that helps what you’ve experienced.

I haven’t even tried it on the old droid. I just know the tiles are great on a 6,7,10" tablet. Not sure how well they would work on an old 2.5" screen sitting landscape in a dock. Remember when a 2.5" screen was so big we were in awe ?

1 Like