Smartthings Waterleak Sensor Doesn't report Wet. Only Temp and Battery level

Just bought two Smartthings Water Leak Sensors, and both paired easily.
The problem is they don’t seem to communicate Moisture to the hub. The device on the Smartthings site shows events for battery and Temperature, but not for water?? The app shows “dry”, but that info doesn’t show in the device in the Smartthings site online anywhere, only battery, temperature, and interval.
The led on the device lights red when I get the leads wet, so I know the device detects moisture, but that information never makes it to the hub. I seached online but I don’t see anyone else having the same problem, I am thinking I should return these. FWIW, I am about 2 feet from the hub, I just received these from amazon today, the included batteries have a date of 2025 and initially showed 100% and now show about 66%.

Have you got them wet yet? when i got mine, when working on programming all i got was null for the water sensor, until i got them wet the first time. then everything worked as i expected.

Yup, got them wet right away. The led on the device lights red when wet, and goes off when dry, but no indication of anything in Smartthings, on the site or in the app. when I check the device in the web site this is all that’s listed for Current States…

Current States:
temperature: 75
battery: 66
checkInterval: 7200

Try the Utilitech sensors from Lowes. I have two and they work great. I’ve tested them both many times and I get an instant alert.
They’re $29. I have one in my basement by the washing machine and one in my attic by the air conditioner drip pan. Rock solid.

I have a few of these and no problem at all. Maybe check the device handler to be sure it’s the right one. Return them if you are using the correct device handler.

I just want to chime and and say I have having the same issues with two of mine and another issue with another SmartThings Water Leak Sensor.

Two weeks ago I bought one SmartThings Water Leak Sensor (from Best Buy)and when i paired it, the device handler showed “unknown”, so I set it from the IDE as the same device handler as the three SmartThings Water Leak Sensor I already have. The issue with this one is it doesn’t have a checkinterval so the battery status never gets updated, but it changes from wet/dry as it should.

Now the other two that I bought last week (from Amazon) showed up as “unknown” as well, when I set the device type in the IDE, it doesn’t update the wet/dry as it should staying dry.

I opened a support ticket (I can’t find the ticket number) last Monday, and the support representative said that she turned it over to engineering as it is an issue with ZigBee devices. I haven’t tried any new devices since then, but every attempt to pair the two newest SmartThings Water Leak Sensor results in the same “unknown” and when changed in the IDE never sends the wet/dry signal.

I was wondering if @Tyler or @slagle could look into this as its been almost two weeks and no result yet.

I recently bought two of the new ST water sensors with the memorial day sale. For me they are working fine with the “smartsense moisture sensor” which is different than the “smartsense moisture” DTH that my older ST water sensor uses. Hope that helps.

I’ve tried both, all of mine which I bought in past three works are using the same handler, that is how I knew which one to use when I got the first “unknown”. I have three SmartThings Water Leak Sensor that i bought a week before the first problem one that are working properly.But the three I got two weeks and a week ago don’t work as intended.

The thing i noticed was the Raw Description of the two I got from Amazon are different then the ones that are reporting wet.

Working: 01 0104 0402 00 07 0000 0001 0003 0402 0500 0020 0B05 01 0019
Not Working: 02 C2DF 000C 00 05 0000 0001 0003 0B05 FC0F 01 0003

I don’t know if that has something to do with it

These absolutely work and in fact they saved me from a huge mess, twice, last week. Keep reading if you want to hear a funny story about that… Last Monday I received an alert while at work about a leak under the bathroom sink. SHM closed the water valve and sure enough when I got home there was a puddle due to a failed shutoff, but just that, a puddle. My toilet sensor saved later that day when leaky shutoff literally blew off the end of the pipe. It was plastic and it failed because it split up the middle. When that happened the water came shooting out and within a couple seconds the toilet sensor got wet and the SHM once again turned the water off. I’m sold.

I just checked and mine are also using the Smartsense Moisture Sensor DTH. You might want to make that change.

You’ll also need to configure SHM or install a SmartApp to notify you when there’s a leak.

1 Like

My issue is the device never changes from dry to wet when placed in water it stays dry.

All six of mine are using the SmartSense Moisture Sensor device handler, but three of them work 100% as expected, 1 sends wet/dry but doesn’t do check interval, and 2 do nothing at all.

I ensured that when placed in water the LED on top goes red/orange but the device handler in SmartThings doesn’t change (the 4 ones that do test ok today).

SHM will be nice once they report they are wet.

(I had my hot water tank leak for a few days before I got any of them, having that water issue pushed up getting all 6 sensors)

Well Support come through in the Clutch. They fixed my three not working devices / device handler.

All six of my SmartThings Water Leak Sensors are working as they should reporting wet/dry, battery, and temperature as it should.

Here is the explanation from support.

“There is currently a known bug on our end which is causing devices to not fingerprint correctly when pairing with the Hub. This is why we have to manually go through and update on our end. We’ve been working closely with our engineers and developers. Rest assured, this will be resolved soon.”

1 Like

Glad they got them working for you! They are in my opinion at least, one of the most useful devices one can buy when coupled with an automatic shutoff.