SmartThings Smart Lock Guest Access - Disappeared (January 17, 2023)

Glad it is back. And appreciate prompt response to the concerns being addressed. But I agree with others, this app is too basic. While I’ve seen others reference the use of SmartTools you pretty much need significant coding knowledge and if I understood-- to get the capability to send SMS messages requires the pro version which is $30 a month? I don’t do rentals but do have friends and an HOA office who may need access. I just need to be able to a) see what codes I have assigned, b} have a text message sent letting me know who unlocked, c) have lights turned on.

1 Like

SharpTools is $3 month or $30 year at current prices


It isn’t back for me (UK using Android). It still can’t get beyond 95%.

You also need the premium version just to do per lock code custom actions because it requires the use of variables :-/

1 Like

Thank you Samsung for fixing this promptly!


Thank you for taking care of the issue!

I didn’t know it was missing until I saw these posts. Yes, mine is missing also in both of my locations and on both my Android phone and iPad. Now it gets interesting. I was going to wait, but thought I would give it a shot to add it back. So using my phone I went to the Life section, hit the plus sign, found it in the list and added it back. It worked no problem. Changed locations and added it there as well. Then I picked up the iPad. The smart lock “service” was there in one of my locations but not the other. If I try to add it, it’s not even in the list of services to add. I don’t get it!

Edit: Never mind. I noticed the iPad needed an update to the ST app. After I did that, Smart Lock is back in both locations.

Edit 2: In the Toronto, Canada area.

1 Like

Still not working for me in the UK.

Goes from 95% to 100%

then quickly looks like its going to install and goes back to white screen page.

Same here. The last 5% loads but to no effect.

I tried a second Location in a different phone and it again starts from 95% and this time I was just able to see ‘Locks’ top left and ‘History’ top right before it fell over.

Update: I’m not clear how ST came to the conclusion that they’d finished fixing the issue over nine hours ago as it remains broken at 11:25am UTC.

ST ver 45.11

Android The server isn’t responding. Try again later Error

iOS No error message, doesn’t install

iPadOS No error message, doesn’t install

Update; Android working

iOS working

iPadOS working

1 Like

back up and running. :smile: had to cycle the locks from the app to get them sinked.

1 Like

Good Morning All,

I successfully reinstalled this morning :clap: :clap: :clap:

As reference for anyone getting stuck/hung-up at 95%: On Android v12, install only took 3 seconds total: Maybe 1 sec to 95% then 2 sec to completion.

1 Like

From forum reports it looks like it might only have been fixed in the North Americas region. :thinking:

If you are in the UK and it’s still not fixed, you could try the UK support options. Don’t expect the first person you speak with to know much, but if you tell them it says it’s fixed on the status page but you’re still having issues it should get escalated to the right team.

UK support options:

Status page:


I am still stuck, I have deleted it and can add it, but I am still unable to add a code. Anyone else still having trouble with that? Thanks!

Problem still persists, i called samsung and they don’t have any uk customer service advisors to talk to. Reported issue again via app so i advise everyone whos still having my issue to do the same so they can sort it.

1 Like

I have the same issue. It would install today, and I can change the Guest name for a code, but I cannot add a new code.

1 Like

i don’t even see the option to re-install it. :pensive: it was there yesterday when this was first reported, trying to install it did nothing but remove the “card” from the life tab. now it’s no longer there and when i hit the plus sign to add a new card, i don’t see the SLGA option anymore.

You can either sign out/sign back into the app or uninstall/reinstall the app to get it to where you can install SLGA again.

oh man, that’s good to know! i happened to see the app had an update when i went to log out. installed the update and SLGA is back now! i imagine updating the app was similar to logging back in.