SmartThings or ethayer doesn't recognize DST? Also, have ethayer lock manager and changing lock codes doesn't activate correctly?

I have an Airbnb. Check-in time is 4pm so I set the code to activate 15 minute prior. Well, it doesn’t start at 345pm. I starts at 445pm because it doesn’t recognize DST. But SmartThings itself recognizes my smartbulbs are supposed to turn on at dusk–and do. There’s a conflict between the two. Maybe it’s ethayer itself. I don’t know.

Then there’s the issue when a guest wants to extend their stay and when I go in to simply change the checkout date the night before, it only says “deleted airbnb guest code.” It won’t say “added airbnb guest code” until 345pm the next day. Now there’s a gap of when I update the code to a later checkout to 345pm that the code doesn’t work.

How can these two issues be fixed?

tagging @ethayer

I didn’t develop the AirBnB portion so I’m not sure. I can say, the Groovy app runs on SmartThings servers and uses their time subscription service, so it doesn’t manage timezones independently from SmartThings.

Maybe the API between the groovy app and AirBnB isn’t using the correct time zones, but I can’t say for sure.

I’m working on making a new LockManager app on the new API platform, but I haven’t touched the code for the Groovy Lock Manager in awhile.

Hi @ethayer. Thanks for the reply. I should clarify about the Airbnb part: I know Lock Manager is not integrated with Airbnb. I only mentioned Airbnb because it’s how I relate the two but together they are completely unrelated. For all intents and purposes, we can remove “Airbnb” from our discussion. If anything, it’s Schlage z wave smart lock.

The issues I’m having with Lock Manager is that when it comes to light bulbs–Cree brand if that matters–they start and stop on cue, regardless if we are ST or DST. 6pm scheduled on means 6pm on! 3am scheduled off means 3am off!

Now, in regards to Schlage zwave smart lock and Lock Manager, that’s a different issue. When I’m setting a guest code for a start time of 3pm, it will start at 3pm on standard time. Since we recently switched over to DST, 3pm scheduled start time is really 4pm start time. I’d have to schedule a 2pm start time in order for it to activate at 3pm. I believe, for now, there is a timezone problem between Schlage zwave and Lock manager.

I had the same issue when last year 2020 we switched from DST to ST, and shrugged it off as some kind of glitch. Now that we’re switching from ST to DST, it comes full circle.

Hope this clarifies things. Thanks in advance.

Ok! Sorry about that. I think I fixed it. Please update to 2.1.2 and let me know if it’s good to go.

Sorry, one more thing. Referring back to my 2nd question the title.

So let’s say I have Shlage zwave smart lock and in lock manager, I have a code set between March 20 (start at 3pm) -March 23 (end at 11am). As mentioned earlier, I run an Airbnb and sometimes a guest wants to extend their stay until March 25. So I go into lock manager, change the end date to March 25. I get a push notification from SmartThings that says, “deleted guest code.” This notifies me that the door code is essentially useless.

The problem is, when I change the end date to March 25, it does not send me a push notification “added guest code” until 3pm, which could be 10 minutes, 10 hours, or a day later, however soon 3pm arrives, because in lock manager, I’ve set 3pm as my start time. If I change the end date at 250pm, I will receive the “deleted guest code” notification at 250pm and receive the “added guest code” in 10 minutes. If I change the end date at 330pm (30 minutes after my 3pm set start time) I won’t receive the “added guest code” until 23h30m from now. I end up with an Airbnb guest who can’t use their code for 23h30m. The easy way out is to create a new user, but that would defeat the efficiency of the original user.

I hope this makes sense. Thank you for all your hard work.

I just pushed another small update because I went a little over-zealous with my changes last night and introduced a bug.

I’m not seeing your issue, maybe you could make a step-by-step in ways to reproduce your issue?

Here’s what I just did:

  • I created a user to start in the past (Mar 20 Start 9am start, end at 10:05am Mar 24)
  • Lets run, code gets programmed.
  • wait until 10:06am, code gets deleted
  • Go into Lock manager and change the end date to the 25th, Click ‘Done’ (start date is still the 20th, which is in the past)
  • Code gets programmed.

This seems to be the desired outcome. Perhaps this issue was related to the timezone issue also?

Success! Great work!

1 Like