SmartThings Nov. 10 Infrastructure Update

Looks like things are coming back…got the Google home to integrate with SmartThings.


There is a subscribe button on

I’ve noticed since the infrastructure update, some of my core Pistons aren’t runningas scheduled AND ones that did say "past due " in the core dashboard when I know they ran as scheduled. @ady624 @slagle

I’ll give it a day to resolve itself before I go into full panic mode😎

Waking up this morning to find problems with changing modes and smartapp execution.

Most everything I run is related to CoRE so the problems may be more isolated there.

Finding many Pistons not working. Must go into each app and press
done in order to make them function again. With over 35 pistons it is
going to take awhile.

CoRE piston seems to no longer be able to execute routines that change modes.

No errors being reported in the log

Scheduled jobs are not running.

Modes are not switching (automatically or manually).

This error shows randomly as different apps run (i.e. ecobee, routine director, etc.).: Access Denied @ line 195

EDIT: We appear to have switch shards. Is that the issue??? @slagle

EDIT 2: Changing mode manually worked after a couple of attempts.

IT doesn’t seem to be isolated to CoRE… but I am also having issues.
Morning mode change for me uses Good Morning routine. That did not work automatically. I had to manually fire good morning, which then switched my mode.

MY CoRE piston which turns on my lights did fire as expected, but it is tied to illuminance and motion, not the routine or time.

1 Like

It looks like bigger problems are afoot. A CoRE piston that was working a 1/2 hour ago is no longer working. It could be going into each piston and pressing done may have been just a placebo effect.

Now picking up errors that were not there before

Also showing errors - in particular:

java.lang.NullPointerException: Cannot execute null+null @ line 997

and Access Denied @ line 327

…all seems to be related to SHM.

All my Core routines have also stopped working it actually looks like all my motion related routines

none of my pistons work that are triggered by minimotes.

1 Like

and there is this chestnut

1 Like

Mmmmm chestnuts…

1 Like

Since when did emojis get love handles?:heart_eyes:

A couple of my CoRE Pistons worked, a couple others aren’t working

Should be interesting to see what Support has to say


im not getting the errors now they may have fixed something but I still cant launch my smarttiles it gives me the logon then jsut takes me to the ST page

oh look ST doing another update that they clearly didnt test properly THANKS GUYS

This error is popping up everywhere now

I agree, seeing it with CoRE and Nest Manager

Maybe @slagle or @Aaron, or @vlad can help look into this?

Seems to be related to the child app executing a parent app public method. Fail. No way I can get out of that with a “patch” ;))

It is occurring on more than just a child app executing a parent app public method. The problem is affecting numerous apps, CoRE is but just one of them. I have dozens failing. Same error for Routine Director (non-parent-child).