SmartThings Community

SmartThings Nov. 10 Infrastructure Update


(Scott) #52

Looks like I’m back to normal as well - reconfiged Security and tried it out - seems to be arming and disarming as expected now.


(Aaron S) #53

Update: there was an issue with part of the migration process that caused SmartApp permission checks to fail on the new servers. This has been taken care of and things should be running normally now. I apologize for the inconvenience.


(Kevin) #54

Seems to be back working for me, executed routine and it switched mode & SHM. Thanks!


(Tino Race) #55

No issues in the UK. Good job we’ve got you Americans to beta test all this stuff for us :joy:


#56

It is not possible to access Installed SmartApps in the IDE. New problem this morning. Those links fail, and return to top level IDE menu.

Actually, all of the links for a Location fail.

THIS APPEARS TO BE FIXED NOW


(Micheal ) #57

There seems to be a ‘redirect’ issue with apps like the Google Home, Alexa, or even SmartTiles login. If you attempt to authentic a device (like Google home or Alexa) the login page comes up and then once you enter your credentials it simply goes to the normal IDE page. For SmartTiles Beta, the same issue…you log into your account and instead of getting the dashboard you go straight to the IDE…


Enable skill not working
(Michael Hess) #58

Same here, woke up to no SmartTiles anywhere. :frowning:


(DLee) #59

Update-- now fixed

I still have this problem with reconnecting in IFTTT. From within IFTTT, select smartthings applet, then “Edit connection”, login, it resolves to top level IDE menu.


(Evan) #60

Now able to disarm SHM, to bad this glitch reset the WAF to low.


#61

ST need to collect spouse email addresses for notification also.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #62

The SmartTiles issue has been posted here on our website / outage notices page:


(Micheal ) #63

Looks like things are coming back…got the Google home to integrate with SmartThings.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #64

There is a subscribe button on http://status.smartthings.com


(might be my fake name?) #65

I’ve noticed since the infrastructure update, some of my core Pistons aren’t runningas scheduled AND ones that did say "past due " in the core dashboard when I know they ran as scheduled. @ady624 @slagle

I’ll give it a day to resolve itself before I go into full panic mode😎


(DanG) #66

Waking up this morning to find problems with changing modes and smartapp execution.

Most everything I run is related to CoRE so the problems may be more isolated there.

Finding many Pistons not working. Must go into each app and press
done in order to make them function again. With over 35 pistons it is
going to take awhile.

CoRE piston seems to no longer be able to execute routines that change modes.

No errors being reported in the log


(John) #67

Scheduled jobs are not running.

Modes are not switching (automatically or manually).

This error shows randomly as different apps run (i.e. ecobee, routine director, etc.).:

org.springframework.security.access.AccessDeniedException: Access Denied @ line 195

EDIT: We appear to have switch shards. Is that the issue??? @slagle

EDIT 2: Changing mode manually worked after a couple of attempts.


(James Yeo) #68

IT doesn’t seem to be isolated to CoRE… but I am also having issues.
Morning mode change for me uses Good Morning routine. That did not work automatically. I had to manually fire good morning, which then switched my mode.

MY CoRE piston which turns on my lights did fire as expected, but it is tied to illuminance and motion, not the routine or time.


(DanG) #69

It looks like bigger problems are afoot. A CoRE piston that was working a 1/2 hour ago is no longer working. It could be going into each piston and pressing done may have been just a placebo effect.

Now picking up errors that were not there before


(Mike Swanson) #70

Also showing errors - in particular:

java.lang.NullPointerException: Cannot execute null+null @ line 997

and

org.springframework.security.access.AccessDeniedException: Access Denied @ line 327

…all seems to be related to SHM.


(phil) #71

All my Core routines have also stopped working it actually looks like all my motion related routines