SmartThings Multi Sensor temperature reading off by +2 degrees every hour

Hi,

I have two older Smartthings brand multisensors with the rectangular shape. They are both showing a temperature reading that is 2 degrees F higher than normal readings every hour. This is causing automations to fire prematurely, before actual temperature thresholds are reached. Does anyone have info on fixing this?

The devices are several years old, take two AAA batteries, register contact sensor, vibration, temperature and orientation(use for garage door).

Thanks!

Open the tile of the sensor and in the upper right hand corner, click the 3 dots and then settings. From there, click temperature offset and enter -2

Thanks Troy , but my issue is I will get temps like this, when the temp should always be 80. These would be readings every 15 minutes as an example. Adding an offset would just make these numbers higher.

80
80
80
82
80
80
80
82

You can make it lower by adding “-” before the number. I did this on one of my sensors which was reading high.

Are you sure there’s not something that’s turning on near the sensors which is raising the temp by 2 degrees? How do you know that the temperature is a constant 80 degrees?

That was just a set of example data. I am streaming the data to Grafana to visualize and noticed it there first. I then confirmed it in the smartthings app looking at the history my minute.

The elevated readings are constantly spaced and happen every hour.

Understood but the questions still remain. However, 2 degrees off at consistent intervals does seem odd. Looking at one of my sensors, the temps change with either an 8 or 3 at the end of each report so that’s telling me that they are reporting change on a consistent scheduled reporting interval but only if there is a change in temperature.

Do you have your thermostat set to circulate on a schedule or do you see these differences when the furnace or ac is kicking on?

It’s possible that there is nothing wrong with the sensors but rather something is driving the overall temperature of your house up by 2 degrees on a consistent basis. Highly unlikely but still probable.

1 Like

Here is some example data over 12 hours - data is being loaded into Grafana, but I have verified the data matches what is in Smartthings app.

1 Like

it could be the age of the sensor.

1 Like

As in no longer supported or malfunctioning? This is happening with two of them - those are each temperature being graphed on two separate units.

That is weird. Definitely a glitch. Try changing the device type in the IDE and then change it back after a couple of minutes.