SmartThings is ignoring 2 new Zwave devices

I had to replace 2 Z-wave switches that were damaged by lightning. I deleted the old switches from SmartThings and then installed the replacements. When they were first connected, SmartThings issued a message saying they weren’t using the highest security level and to delete the devices and add them again. So, I deleted the new devices and tried readding them to SmartThings a second time. Now, SmartThings won’t recognize them at all. However, when I check the event list, the messages are being broadcast on the Zwave channel. SmartThings just ignores them. Any idea how to get SmartThings to recognize these devices? Event list included as an attachment.

Try to exclude them and then add them back.


Exclude the devices first

When I posted, I had tried excluding the devices several times but the SmartThings hub didn’t register them during the exclude process. Today, I tried the same procedure again and it worked the first time for both devices. Go figure. Anyway, thanks for the feedback. This issue is now resolved.