SmartThings IDE Shows Z-Wave: Not Functional

I bought a new SmartThings hub and have not been able to connect a single Z-Wave device. Not a single one. I have GoControl Light Switches that wont connect and GE light switches that wont connect. New devices out of the box. I have no Z-Wave network yet because I haven’t been able to connect anything. I have extensively Googled the issue and found the IDE site. There it shows that my Z-wave state as Not Functional. I have gone into utilities and enabled Z-Wave module. I have tried to repair the network. I have tried to exclude the devices. I have reset the hub to factory more times than I can remember. I have emailed support. I have not called them yet due to horror stories of everyone else calling the. I’m about to return the stupid thing. I should mention that I have no issues with Zigbee devices and they connect in about a second. I have used the new app and the classic app. I have tried the repair and it just shows the circle. I imagine you cant repair a network that doesn’t exist. Oh and the LED on the hub never blinks to indicate it is in inclusion mode. Nothing is working! What am I doing wrong, what is wrong with this thing?

You aren’t doing anything wrong: if the IDE says the zwave module isn’t functional then the hub can’t communicate with any zwave devices. And if rebooting the hub doesn’t fix it, it may just be a defective device. It’s aggravating, but it happens with all electronics. It’s like bringing home a new television, taking it out of the box, and the audio doesn’t work.

These days it’s usually more effective to call support then to email them, so you can try that and see if they can see anything from their side, but it’s likely that you just have to return the hub and get a new one.

Sorry there aren’t any tricks for it, but if you can’t enable the Z wave from the IDE, there’s not much else you can try.

Oh, we should also ask what country you are in and what’s the exact model of your hub.


United States. Specifically Texas. Hub M/N: IM6001-V3P01 Firmware 000.026.00009 Controller Version 1.7.34-26. Its new, haven’t had it a week yet :frowning:

Try to reboot the hub. Check your hub logs of the Z-Wave module is stuck while upgrading it’s firmware.

I’ve rebooted the hub more times than I can count. Unplugged it, waited, factory reset it, reset command from the IDE. You name it. Can I update the firmware to fix it maybe?

You’ll need to check if your Z-Wave module is stuck in the upgrade mode first. Open the IDE, click on Hubs, click on List Events, after rebooting the hub see what messages show up regarding your Z-Wave module.

This is a known issue with the current hub firmware. I believe a root cause has been identified and the fix will go out in the next hub firmware update.

Typically rebooting/powercycling the hub should allow the Z-Wave firmware to update which resolves the Not Functional status. I have encountered a few stubborn ones such as yours but you should be all set now.

1 Like

A fix for this issue is in the hub firmware hotfix, version 26.12:

Not solved or anything. Z-W not working.

Samsung updated firmware or something and it’s worked fine since.

Thanks @Joel_Wallace but it looks like my hub is z-w silent.
I’m switching to Hubitat.

1 Like