Smartthings Hub Issues

Trying to figure out what is going on with my hub. I have a call in to Samsung waiting for a call back or email, but who knows how that will go.

I have a Samgsung hub (v3). I have a mix if Zigbee (door and water sensors) and Zwave (light switches) devices. What is happening is that the zwave seems to be slow or not working. You can click in the app to turn a light on but it just spins and it does not do anything. You can turn the light (zwave) on manually and the app will sometimes see the change and sometimes it does not. After a wait it will usually finally see it or sometimes the app will turn them on minutes later. This is all the zwave lights. I can restart the hub and they will work for a little while. I can also go in the hub and repair the zwave and it will work for awhile. then it stops again. Maybe a bad device but how to find that?

I do not want to factory reset the hub but not sure if that would even fix it. Also if I do that then is a newer but hub to get?

My 10 cts
-unplug the hub and leave it for 20 minutes
-go to Samsung account and take a look at your devices.maybe gives it a clue.
Or go to

And see what happens when you click on your zwave stuff

Sorry. The only thing I can offer for now

The only newer hub is the Samsung station which has very similar technical specs and doesn’t have Z wave, so it’s not going to be any help. :thinking:

Multiple community members have reported similar symptoms if the hub is running low on memory. Which in this community most commonly happens when people have downloaded a bunch of custom edge drivers to try out.

Are you running any custom edge Drivers? Particularly zwave ones?

Also, have you run the “Z wave repair“ utility and if so, did you get any error messages?

Is the Aeotec hub the exact same? I look at the Station but the zwave is the issue.

I thought custom edge drivers went away with the new system. I might have loaded one way back but not in the new system.

As for the zwave repair errors, just that a couple of devices are offline. On my phone is takes forever or does not seem to even run but it repairs the issue. I ran it on my iPad so I could leave it on and then the offline errors.

I did not try the 20 unplug. I did look at my devices on the website but everything looks fine.

The 20 minute power off trick has the effect of causing the Zigbee mesh to rebuild itself. Unlikely to be of help with z-wave.

Factory reset is your absolute last resort for a totally broken system. If you do that you’ll need to go thru the pain of adding each of your devices one at a time, including probably needing to factory reset each device and “excluding” each z-wave device. And then rebuilding everything about your deployment.

No, edge drivers are part of The New Architecture. Including both stock and custom drivers.

Some sort of issue with your z-wave mesh seems likely. Any battery-operated z-wave devices that could be getting weak? Any device recently added?


I agree the 20 minutes is a Zigbee thing. Sorry

Custom “device type handlers“ (or “DTH’s“) went away with the new system.

They were replaced by “edge Drivers“ which can be either stock or custom.

Custom device type Handlers ran in the smartthings cloud, but custom edge drivers run on your own hub, which is why having too many of them can slow things down. :thinking:

Oh, and the Aeotec hub is basically a clone of the smartthings V3.


I added one lately but thought the issue was happening before that but also had some other network/wifi issues going that I might be confusing it with. Going to remove that one and rebuild the zwave and see what happens. Had a couple of other zwave devices that used to online and re-added but not sure about the timing. No battery devices.

No on any new custom edge drivers.


Is the issue happening with all z-wave devices or only certain z-wave devices?

can you list some of the z-wave devices (brand/model) and the Edge drivers being used?

Seems like it is all zwaves but they are the same type and brand. I did find a different one, Somfy screen, and it is not working too. It is like the zwave network is overloaded and nothing is getting through.

All lights are Leviton Z-wave dimmers and switches. Leviton DZ15S Decora Smart Switch & Leviton DZ6HD-1BZ Decora Smart 600W Dimmer. On the website it says the driver is the Zwave - switch.

Removing the newest added device did not change anything.

Great now it looks like the latest app update had broken adding Leviton products. Crashes on trying to add devices. On Iphone and Ipad and uninstalling and reinstalling. Fun.

I have a few of each of those. The Z-wave Switch driver should be fine. For what it’s worth my z-wave mesh is 100% non-secure (S0).

When I got my Leviton devices about 5 years ago they had a firmware issue that caused them to randomly drop offline. I’m not actually sure how or if you can determine the firmware version from any SmartThings interface. There’s some chance this is your issue.

Z-Wave S0 is encrypted, and an old, chatty protocol. It is not really recommended for a stable, performant Z-Wave mesh. Z-Wave S2 is a much newer and more secure encryption scheme, and much more efficient. Personally, I’d recommend not using any Z-Wave encryption, except on Locks, Garage Doors, and other ingress/egress actuator devices.


Me and a few other users have recently had problems with these Leviton switches after a recent firmware upgrade. I tried everything and finally had to exclude them and then factory reset them and add them back to ST.


Ok I think I figured it out. It was the last device I added. Removed and let it set for a day and no issue. It was an Aeotec Multi sensor 7. Going to try and add again today and see what happens.

I was have other issue with router and WiFi and did not realize when I added this a different issue popped up.

Also thanks for the info on the firmware issue with the Leviton devices. Most of mine are 3-5 years old and in know the firmware has not been update and I have those issues with them dropping. Order and usb stick to work on updating the firmware in those.


Added back and so far so good.

Cannot fix the other issues with missing devices since latest app update has broken adding Leviton products. Crashes evey time on different devices trying to add.

if Android, you can trying installing a previous version from an apk site