SmartThings Hub 2 integration with Velop?

hi folks - I’ve had a SmartThings hub since day 1 and upgraded to a Hub 2 when that was released.

I just switched my router to a Linksys Velop (3 node units that comprise a mesh - configured as a master unit, connected to my cable modem, and 2 child units). The hub now fails to light up when connected via cat 6 cable to one of the two child units. It seems to work OK when connected to the base unit however.
I also have a Hue Bridge which works OK on the child Velop unit.

Because of my house setup, I can’t permanently connect the smart things to the base unit, so need to find a way to make it work when connected to a child unit.

Any ideas?

Does your ST hub have an IP address on your new LAN?

No. When attached to the child Velop, it doesn’t even light up (no flashing lights on the Ethernet port), and isn’t registering on my network. (I think i read elsewhere on this forum that the lack of lights was a separate issue that occurs when the device fails to register on the network)

It does have an IP address when I attach it to the base Velop unit.

I have also tried this with and without batteries in the device. No difference.

I’m totally out of my depth here but suspect that the child Velop isn’t handing out an IP address to the ST hub (even though the same Velop unit appears to be doing so to my Hue bridge. Maybe that’s due to the technical difference between a hub and a bridge?)

Philips did a recent update in November 2017 specifically to improve Hue Bridge discovery on WIFi mesh. Which implies there are some known technical issues.

Yeah I’m certainly not a networking expert either, but it sounds like your router/mesh system isn’t handling DHCP well, assuming that’s how IP addresses are assigned on your LAN.

Can you assign a static IP address to your ST hub in the velop admin page?

Perfect. Thanks Mark

  1. I attached the ST hub to the base unit via Ethernet
  2. I used the Linksys iOS app to get admin access to the Velop
  3. I found the ST hub on the list of attached devices (this was a bit trial and error because i couldn’t find the identifying MAC address, so I kept unplugging and re-plugging the hub to see what device disappeared and then reappeared in the list) and then selected that item.
  4. I simply clicked on the “reserve DHCP’ words to the right of the IP address of the Hub.
  5. I unplugged the hub from the base Velop and plugged it into one of the child Velop and it worked first time.

Problem solved. Thanks again.

1 Like