SmartThings DSC/EnvisaLink Integration (Working Solution)

Which DTH are you using? Just as a test, change the exit delay to 59 and watch Live Logging. Does it still show errors?

I’m thinking probably the hub is not bound to a location, causing the location var to be null and thus resulting in the NPE.

@segarm can you validate/verify if the hub is attached to a particular Location in your app?

Yup, exactly. I just saw that in your Github code. I’m betting that’s it.

That’s your code :stuck_out_tongue:

1 Like

Well don’t forget to give credit back you yourself as well, you did all the heavy lifting and effort!

Lol I meant your line of code.

1 Like

Thank you @vadimb & @johnconstantelo for helping me setup an automation (with my SmartThings Ver-2 Hub)!

Yes, my hub was not bound to a location. I added it to a location in my SmartThings app - now I don’t see errors in “Live Logging” but it still isn’t arming my EyezOn security.

Please see an image about it from SmartThing’s “Live Logging”

How are you arming it? Leave live logging up and turn it On (via the new app’s UI). What does live logging show?

Also, do a Refresh and what does live logging show? To do a Refresh, press/hold the on/off button and pull down. When you do that you will see the refresh icon, so when you see that let go and it will refresh, like this:

And then Live Logging should show these messages:

image

Thanks for the information, @johnconstantelo and @vadimb! My apologies for the delayed reply.

Attached is what I have…

  1. Device list shown in my ST App

  2. Eyes-On Stay - Cloud device

  3. ST automation routine

  4. Live Logging showing details when STAutomationRoutine ran at 3:30PM. The log shows the System status is “unknown” but my Vista20P security was “Ready” for arm.

  5. Live Logging showing details when I “Refreshed” the Eyes-On Stay device at 4:42PM in my ST app.

Hello @johnconstantelo & @vadimb

Please ignore some information you see in my previous post (#89). I apparently had a custom partition name in my Eyes-On account - that’s why the ARM sequence couldn’t find the current status of my Vista-20P.
After updating the custom partition name (in the switch), the arm sequence is correctly identifying the status but it’s still not arming my system that is “ready to arm”. Please see the attached log.

I now have 59secs exit delay in my switch but I know my exit delay is much longer than that in my Vista-20P panel. Could that be the reason?

Now that you got past the initial problem I suggest you try the other device handler code. I’m betting that the variant you installed now is not the correct one for your system.

Also do make sure that you set the delay in the app to line up with what you configured in your system. It’s not essential for making the alarm arm/disarm but is important if you want the app to automatically refresh with the up to date status.

Hello @vadimb

I switched the Device Handler to version-02 from version-01, and changed the delay settings to 120-secs in the switch (please note; my Vista-20P’s exit delay is 90-secs) - I still see the same information in the logs and my system does not arm :frowning:

Please see the attached log.

Welp, my problems persist. The system always seems to arm fine. Sometimes the system successfully disarms when I manually execute the “Disarm” routine (that just turns the switch off). Sometimes it doesn’t work when I run manually. But, it NEVER disarms when I run the Disarm routine according to a schedule. You can see this morning, the system tried to turn the alarm switch off 4 times – 6 AM, 6:03, 6:05 and 6:30 (all on schedules I set for multiple tries) – but when I woke up at 7 the system was still armed.

Capture|690x367

Also, while the system is supposed to arm at 1 AM, and always arms fine manually, I have noticed in my New App history a couple times where the switch didn’t get set to “on” until 2 or 3 hours after the routine ran (and I was already asleep)…perhaps that’s what is happening with my disarm–it’s just taking a long time to work through the internet, and I’m waking and disarming before the auto-sent command executes?

Any thoughts are appreciated! Also, I’m feeling dumb, but I’m having trouble with “Live Logging” in the IDE – I just get a message that looks like what Segra posted in Post 78 which never updates…

Thanks!

I can arm and disarm my alarm via the eyezon app. I can also turn on and off lights via the smartthings app but I receive the following error regardless of which device handler I use.

“A Network or server error occurred. Try again later”

Log:
Determined system status to be Unknown at 09-23-20 8:17 PM
Received request to disarm system. Mode: Away