SmartThings doesn't see the Sonoffs as a switch

I flashed the Sonoffs like this, have successfully added them to my WIFI network, and added them to ST like this

I only diverged from these videos in two ways: used Sonoff-Tasmota v5.14.0 since the wireless wasn’t working with the version mention in the video and I had to manually enter the Sonoff’s IP addresses to Sonoff Connect since they were not being discovered.

ST doesn’t provide a GUI option to toggle it as a switch and Simplify doesn’t load them either.

I flashed them with sonoff.bin and not sonoff-allsensors. Do I need to configure them to work as sensors or switch somewhere in the Sonoff-Tasmota web interface?

1 Like

If you are trying to use @erocm1231’s SmartThings App/Driver code, you also need to use his firmware for the Sonoff device.

1 Like

Thanks ogiewon.

I will give that I try.

1 Like

I followed the direction provided in the Sonoff: $5 Smart Switch! Works with Smartthings! YouTube video ( and it seemed that the flash took but no WIFI. Followed the no WIFI comments and flashed it with NodeMCU flasher with these directions: [RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches). Still no WIFI.

When I previously flashed it with sonoff-tasmota the green light would flash when power was applied and I could access it’s web interface, just couldn’t get it to work with ST. Now it’s just dead with no lights and no WIFI even though NodeMCU flasher loaded the flash.

Does any one know how to get Sonoff-Tasmota v5.14.0 sonoff.bin ( flash to work with SmartThings?

I have flashed a bunch of these, some had the same results as you with no green light, usually I just reflash with a different tool (ESPFlashDownloadTool_v3.6.4) and they seem to work after. I have over 20 of these and they have been pretty solid.

1 Like

I have about 15 Sonoff basics running with the latest Tasmota firmware. What I did was download espeasy-mega ( There’s currently a bug in the latest release of the compiled sonoff*.bin releases ( Instead, I downloaded and used that with FlashESP8266.exe. Once I did that, my Basics all worked fine on mains power.

On the ST side, I used as my DTH.

1 Like

Thanks for the information. I will give these a try tonight.

1 Like

I did this.

In the old ST app I see the device and it always shows as on, even if I toggle it. When I toggle it I can hear the relay clicking on the Sonoff.

In the new ST app I see the device but their is no GUI option to toggle the device.

1 Like

The DTH might need to be updated for the new ST app (I refuse to touch that garbage app until Samsung forces me to :wink: ).

Out of curiosity, did you backlog your settings to your Sonoff or set it up through WiFiManager? Also, did you setup a username and password for your Sonoff? On all of mine, I don’t have a user/pass and I set mine up through backlogging in Termite. You might need to go into the web console and tweak things around a bit. I had to make sure that for all my Basics, GPIO14 was set to 09 Switch1.

I have the same problem: after flashing and WIFI connection it works with the Smartthings Classic app but keeps with “Checking status…” and “Can’t connect to device” with the new app.

Did you find a solution?