SmartThings CLI: LAN driver logs disappeared (hub discovery not triggering)

I am not sure this is firmware related. I am still on 000.044.00009 and have the same issue.

@nayelyz , @taustin @orangebucket @Automated_House

I have been talking with some developer friends of mine who have been looking into recent Bluetooth issues for other systems. I’m going to pass along what they said just in case it’s relevant to what’s happening with the smartthings app. Could be just a coincidence, but it’s the same timing.

This appears to be a case of Apple saying “and this time we mean it.“

Part of the Bluetooth spec for apple has always defined how the Interval Max and Min would be handled when a Bluetooth device was connecting to the iOS device, but apparently they never enforced it until iOS 16.

Now they are enforcing it, and the result is that some Bluetooth devices, maybe including the smartthings hub, are timing out in situations where they didn’t used to time out.

People who have this problem likely have it over and over again because of the configuration and what they are trying to do. But there will also be quite a few people who don’t have the problem.

Some device makers, like the manufacturers of the Whistle GPS tracker, are fixing the issue by putting out new versions of their apps which comply with recommended practices. others are waiting and hoping Apple goes back to the old strategy.

We are developing a device which communicates with our iOS/watchOS apps via Bluetooth LE and has to stream a lot of sensor data for an extended time period (hours). Everything works fine under iOS 15.x, but we’ve found out that iOS 16 betas (and the RC) changed something in the negotiation process: previously we’ve used 15 ms Connection Interval, but iOS 16 (and watchOS 8) most of the time negotiates 24 ms, which is too wide for our bandwidth. The long connection interval causes packet loss (9-33%), and after 3 failed retries (3x30 sec) our hardware drops the connection.

Here’s a discussion of the fact that the Apple spec hasn’t changed, but the enforcement has.

iOS 16 changed Bluetooth LE Connection Interval - Stack Overflow

even if it was in the spec I never saw this behavior during countless hours of testing until iOS 16 and now multiple customers are reporting.

It’s like a township suddenly enforcing a 25 mile an hour speed limit when they used to let people get by with 30 to 32 and now a bunch of people are showing up late to work. But the ones who always drove under 30 don’t see any change. And the street signs haven’t changed. Just the enforcement.

Again, I’m not 100% sure this is what’s happening to smartthings users with regard to adding a new hub or some device discovery, but it might be related. :thinking:

1 Like

@JDRoberts what you said makes sense but my wife hasn’t updated to iOS 16. She’s still running iOS 15.6.1 and has the same issue. Again I’m not an engineer or anything this is just an observation.

1 Like

It’s always possible the smartthings engineers are aware of the iOS 16 issue and that in trying to fix that they broke something else. Or it could all just be a coincidence.

It’s the first explanation I’ve seen, though, of why changing something on the hub Might then affect only a specific subset of phone app users trying to add new devices to the Network. If there’s a timeout occurring between the hub and the iPhone, it would explain why android users weren’t affected.

But again, it could all be a coincidence. I just thought it was worth mentioning.

1 Like

This is working to a degree. Its allowing me to pair my sockets but they are adding and not letting me use edge. I cant even select an edge driver as its not adding as an edge device.
Any clue why this would be?

Hub reset solved this. Sockets all working like a dream

4 posts were split to a new topic: [iOS app] STHM issues with the settings page

As another data point -
I first noticed this about a week ago when a Zigbee device dopped off and I couldn’t re-pair it, then in testing couldn’t re-pair anything new or old as the hub wasn’t scanning.

I was running IOS 15.1 (I think 15.1, the version before 15.6.1 anyhow), so I updated IOS to 16 and the problem still persists.

Glad I found this thread as was otherwise (still are) at a lose-end but sounds like the ST engineers are working on a solution?

1 Like

Welcome to the SmartThings Community, @Channelk!
Yes, the engineering team is working on a solution. Currently, there’s a workaround for Zigbee/Z-Wave devices which I shared in this post:

Please, let us know if this works for you.

1 Like

I am absolutely pulling my hair out at the moment. Many (but not all) my sensors are off line some are malfunctionning (I had a smartthings door sensor that registerred vibration but not Open/close) and worse of all I cant seem to reconnect them. With all the changes over the next few months I think this is going to break my smarthome on an almost daily basis. I had a load of Frient motion sensors that all went off line and all my Fibarro door sensors stopped working and I cant reset them.

I have several webcore routines, I use action tiles and have several custom device handlers. I know these are all going away shortly and I feel I have wasted a lot of money and lots of time setting up a smarthome which is about to become scrap metal.

This technology is just not ready for prime time.

Platform outage:

I just received a text from the SmartThings Support I was dealing with. They rolled back on the update that they think was the issue that was causing the hubs not to find new devices. I just tried it and it worked perfect.

Here is the text I received

Now this worked for me. They had access to my hub. Hope this helps


Looks like the issue is now resolved. Thanks

1 Like


Please help me. I just have this problem this morning while i transfer all my device to edge driver.
Now when i press scan for nearby devices, green led don’t flash as usual. Led stay solid.
I also use ios16.

I did. Power off and on hub. Reboot phone and app.

Anyway to make reset or any solution.
Or any temporally solution.

Hi, @Sup_Ruchanekornkrail

This issue was solved a while ago, and I haven’t seen other reports about it. I just made a test and it worked correctly.

Could you help us by providing the following info, please?

  1. Which version of the app are you using?
  2. Do you have a V2, V3 or Wi-Fi hub?
  3. Have you seen if something appears in the logcat of the Hub?
    For this, you need to set up the ST CLI and run the command
smartthings edge:drivers:logcat --all

You’ll find the Hub’s IP address in the IDE > “My Hubs” section

  1. Did you install a driver compatible with your device or make sure it is supported by the ones in production?

Hello @nayelyz

  1. My version is I think the latest one.
  2. V3
  3. I attached file as the link below.
4. Not sure I install many drivers from community developer. I should uninstall the driver first?

I also can’t uninstall the driver as below picture.

When you captured those logs, you hit “scan nearby”, right? I see there are some consecutive “debug” logs for different drivers. That happens when you trigger the discovery in the Hub. For example:

But, it seems no driver is initializing or getting a new device, were you trying to pair one?

It depends on the device you’re trying to pair, if there’s a driver owned by ST that has your fingerprints in the production Channel, it will be downloaded automatically, if not, it will get paired to the most compatible element, it could be a DTH in case of Zigbee and Z-Wave.

About this, have you verified there are no devices using that driver?

Hello @nayelyz

I captures the log when i don’t press the scan nearby. I will make the log again when pressing.
I think all debug driver in the lists are working on my hub. I also confuse.

Seem like now i can’t uninstall all unused driver. I will have the error as last post.

Now when i press scan nearby green led still solid. Do you have any solution for this so i can add more devices? Or i have to do the factory reset?

***edit added CLi when pressing “scan nearby” now I can’t uninstall any drivers.

Hi, @Sup_Ruchanekornkrail

Sorry for the delay.

About this, can you try doing it from the CLI, please? The command to uninstall a driver is:

smartthings edge:drivers:uninstall

Share the error message shown there to see if there’s more information.

Please, try this workaround:

There have been issues in the past where users lose access to those channels they previously enrolled in after a factory reset, so, if you decide to do so, confirm if it happens for you. (You will get a spinning wheel on the channel’s page). If that’s the case, I can ask the engineering team to fix that.

Hello @nayelyz

I try to uninstall both unused and used driver, I got the same error as below. See also in link below.
Error: Request failed with status code 500: {“error”:{“code”:“UnexpectedError”,“message”:“unsuccessful-http-call

I try but still not working. The green LED stay solid and can’t pair the device.

If no further solution, I will try to do the factory reset.

Anyway, thanks for your kind support.

Hello @nayelyz

I did factory reset my hub. After that I added hub to my account via smartthings app.

Then I got all my edge driver back to the hub.

I still faced the problem as before.
1.Can’t scan nearby to add device. Solid Green led
2.can’t delete any driver. Same fault as before.

How can i remove all the driver from my account?
Hub already did factory reset.

I want to start everything from zero as i stuck this issue for many days.

Please kindly help me.