SmartThings CLI: LAN driver logs disappeared (hub discovery not triggering)

Sometime between yesterday and today, I’ve lost the ability to get logs when running smartthings edge:drivers:logcat when filtering by my Edge driver. If I let it show “all” I do see a bunch of activity, but my LAN driver is silent, even when I scan for local devices on the mobile app. Stuff I’ve tried:

  • Opening a new terminal
  • Re-publishing the driver with smartthings edge:drivers:package -I (no changes have been made to it over the last couple days that I remember)
  • Restarting my hub

Still nothing. Is there anything else that could be causing it to just stall here?

Hi, @brbeaird!
Does this driver have at least one device associated with it?

Not at the moment. I’m trying to get it to trigger discovery when I hit “scan” in the mobile app.

It had a device earlier, but I removed it while testing some changes.

Mmmm this is weird, when you hit scan, you should see at least the driver initializing, even if the device isn’t discovered for some reason.

  1. Have you seen in the API if the device was deleted correctly?
  2. Is there anything that could be blocking the driver execution like an instruction before driverName:run() and outside the lifecycles/handlers?

This is something I can think of while I check with the team for other reasons.

That’s what is so odd. Running smartthings devices does not show any devices of this driver type, so I don’t think it was a delete issue.

I am not sure what would be causing blocking like that, especially after trying a hub reboot. Logs do show other zigbee device activity as normal - there’s just nothing for this driver, but in the past, I’ve been able to easily get logs even if just init.

Looks like @TAustin is having the same issue

1 Like

Yup, but no logs is just a symptom. The driver definitely isn’t starting and running discovery.

1 Like

It’s possible your driver is locked up or stuck in a reboot loop. I would modify your init file and comment out the guts of it. Reinstall that with a few log statements for sanity. If it is locked up, this should get it out. Then you can reintroduce your logic and debug the cause.

Erm…I just experienced this. When I investigated, it seems the hub is not scanning. no green light blinking and no events on the old ide.

Is your hub definitely scanning?

1 Like

Already been down that path. Also tried another working test driver that really doesn’t do much of anything. I simply changed the driver name and package key in the config file. Same deal - installs fine, but never gets kicked off.

I agree - by all signs, it looks like this is something that happened with discovery. FWIW, I’m also on firmware 000.045.00007.

Can you see if your hub light starts blinking green when you trigger scan nearby?

It does not. Stays solid green.

I dont think the hub will add anything…

Hi everyone. Thank you for adding your comments on who else is experiencing this behavior. I already asked the team about this.
Are you using the iOS or Android ST app?
@brbeaird, @TAustin, @Davec

IOS. Iphone

iOS for me

I’m Android, and have V2 hubs on 000.045.00007 and 000.044.00009. Both scan fine, and flash green while scanning.

1 Like

Oh. That’s interesting

When you say scan fine. Do you mean edge drivers perform discovery as usual?