SmartThings Community

SmartThings Classic app: How to sign in if I used the V3 app first? It’s asking for a welcome code

I am new to this site, so greetings!

Here is a synopsis of my problem: I was using an Iris (by Lowes) security system until Lowes discontinued it. So I switched to SmartThings because most of the Iris devices were compatible. But because the Iris keypad wasn’t easily compatible, I downloaded the ActionTiles app on a tablet to use as a keypad for the SmartThings app. But I soon discovered that the new version SmartThings app was not compatible with SmartThings for home security. Since the original SmartThings Classic app is compatible with ActionTiles as a home security system, I downloaded this app. But it appears that a ‘Code’ is needed for this Classic app. I tried contacting SmartThings Support by phone about this problem on a couple of occasions, but this has been fruitless! Thank you in advance for any assistance you can provide!

Click on the More tab and at the bottom of the screen, check to see if you have two locations and change to the other one,

1 Like

I’m not sure if I followed your instructions correctly, but on the SmartThings app (on my phone) I clicked on the ‘Manage Location’ tab and the ‘Geolocation’ tab indicated that I only have one location (my home address). I also tried the SmartThings Classic app (on my tablet) again but I am still being prompted to input a ‘Code’, of course which I don’t have and never had. As I mentioned in my original post, I downloaded the V3 app first, but subsequently downloaded the Classic app on my tablet to use with ActionTiles as a keypad. Thanks again for any assistance you can provide.

Geolocation is not what I was referring to. In the Classic app, click on the more tab. Instead of clicking on the cog which takes you to geolocation, click on the down arrow to the left of the cog. There you may see two Home locations for your hub and you can choose the other.

Another place you can check to see if you have two locations is to login to IDE at https://account.smartthings.com and click on My Locations. You can change the default location there as well.

I am not able to get very far with the Classic app. After signing in with my user name and password, I am taken directly to the screen where it requests that I enter a ‘Code’. So I am not able to access the tabs you are referring to. I also logged onto the SmartThings site you referred to, but was surprised to discover that I don’t have any ‘locations’ or ‘hubs’ on this site, which I don’t understand. Again, thank you for all you help!

When you try logging into the Classic App, it should as if you are a new or existing user. Which one did you select? Believe it or not, I believe you should pick New User and enter your Samsung login credentials. See if doing so bypasses the hub discovery process (i.e. you need a code prompt.)

Thank you for your reply. I have tried clicking on ‘New to SmartThings’ on several occasions, but I receive the message “This webpage is not available”. Not sure why this is happening.