SmartThings Button won't work over 4 feet away from hub?

I just received a ST Button and wanted to use it to turn on a light… sounds simple enough right??

I had an Xiaomi button that worked GREAT for several months but recently it, along with all other Xiaomi motions and temp sensors, started going offline daily!

The ST button seemed to pair just fine and I set it up with the light but then I noticed that it was showing “pressed” at all times and wouldn’t work. Nothing I did would change this. I removed and re-paired to no avail…

I contacted Amazon and it was replaced with a new one (assuming the original was faulty).

I just got home and as per the instructions…

I walked over to the counter that the hub is on…
I set the button next to the hub (must be within 15 feet to pair)…
I opened the app and hit the add (+)…
I removed the battery isolator pull-tab and waited…
The button popped up and I renamed it and saved it…
I went into the devices and sure enough it shows PRESSED only!?!?!?!?!?!

Now I got to messing around a bit and I have found that apparently “pressed” means released!

If you double-hit it the status will change to “pressed twice” then revert to “pressed”
The same is true if you hold it down… shows “held” then goes back to “pressed”

Ok… so it DOES work… I went ahead and set it up to control the light and put the switch where we wanted it… it won’t work!

I kept messing with it until I found out that it will work fine only if the button is within 4 feet of the hub!!??!!

This can’t POSSIBLY be correct… can it??

Literally if the button is placed next to the hub it controls the light fine but if I back up over 4 feet from the hub it won’t work!!

I even verified that the original button works EXACTLY the same (I haven’t returned it yet).

I’m having a hard time believing this is correct…???



You might want to start with a SmartThings Support call…

Perhaps others on the SmartThings Forum will suggest other ideas!

Well… I did call ST support this morning and guess what??

I was told “Well there’s several known issues with these buttons… and not working past 5 feet away is one of them…”

His only suggestion was to reset it (through the reset hole) and then re-add it… which I had already tried with both buttons to no avail.

Holy crap!! Why are they selling these if they KNOW hey don’t work?!?!



the button and Xiaomi device both use zigbee. Both of them having issues may point to a zigbee network issue. You change anything with your wifi network recently? how far is your hub from your wifi access point?

Hmmm… Zigbee…
Well, the hub is less than 3’ from the router. Nothing has been changed except trying to replace the Ziaomi button with the ST button.

I checked other Zigbee devices and found that the only remaining Zigbee device, a plug in the barn (over 75’ and 3 walls away) was fine and controlling some outside lights by command and by schedules… until yesterday… now it’s offline and cycling power to it is no help… :frowning:

You may be on to something…

1 Like

If start with moving your hub 10 ft away from your WiFi AP. Then check the channels on both for interference