Smartthings Button - Strange Behaviour Solved

I bought a Smartthings Button as a simple, discreet way to switch off the whole of my integrated security set-up if it went into an Alarm state. I incorporated it into a WebCore piston and tested it successfully. For a discreet location I attached it, via it’s built-in magnet, to the door of my refrigerator.
I never needed to use it until we were leaving for a long holiday and I was demonstrating it to a friend who would be keeping an eye on the house whilst we were away - it didn’t work. No combination of pressing, holding, or pushing had any effect. I took it off the refrigerator and into my office for further testing and it worked! Turns out that whenever the button is attached to metal via it’s magnet it ceases to function, or only functions intermittently - go figure!

Thought I’d post this in case any else out there is having similar issues.

I’ve ordered another button just to see if it has the same problem!


It was also possible that the big block of metal you had it attached to was blocking the signal. To test that, you could try just taping it to the refrigerator and see if you get the same effect. :wink:

Unfortunately, I’d have to remove the magnet to do that. I also tried it on my much smaller coffee machine and got the same result!

1 Like