SmartThings App won't work when iPad connected to 5Ghz?

Just installed a new SpartThings Hub and directly (Ethernet) connected it to my network. Network is a Gen 2 Eero Wireless Network. Was told by tech support that even though I am hardwired to my network by Ethernet, the SmartThings App will not work correctly if connected to a 5Ghz network and will only work if connected by 2.4.
When first connecting Sylvania lights, system saw the lights and worked once and ONLY once. After that the lights would not respond and I received Network errors.
Suggestions? (and no, I can’t force my iPad nor my Eero system to only connect 2.4).

I use the app on my iPad on 5G all the time, so I’m not sure what they were referring to. It might be an issue during initial set up, that’s true of a lot of home automation devices, but it shouldn’t be a problem after that.

As far as things working or not working, they were doing platform maintenance today, so this morning a lot of things were goofy.

What model are the lightbulbs?

Two different manufacturers, Sylvania and GE. I solved the problem by loading the classic app first and let it find everything. The classic app was a breeze to set up and it immediately found every last compatible product. After that, all the lights were in the new lifestyle app.
Lesson learned, start with the classic and then fine tune with the newer app.
BTW, the support line was wrong. iPad app works just fine in 5G.

1 Like