Smartthings app on Family Hub Refrigerator

Has someone successfully managed to control smartthings devices using the app on the refrigerator.
I have added the refrigerator to my smartthings network.
I can see in the mobile app when the refrigerator doors are opened or closed.

However, when I open the smartthings app on the refrigerator I only get an empty welcome screen.
No location, rooms, devices or scenes appear.

The app on refrigerator is version 4.0.88.
My smarthings hub is the 2018 version with firmware 000.032.00010
The phone app is version from August 20.

Check to see if a second location was created. Perhaps you simply need to switch locations to where your devices are.

Click on the menu (3 bars in he upper left of the screen) and look there.

I guess the location would appear in the drop down on the second picture.
The box is empty and nothing happens if I press the down arrow.

I have never seen it before. You logged in with the same Samsung account?

Unless someone has an answer, you may want to contact ST or Samsung support?

I have previously tried to reset the refrigerator to factory settings without success.
Now I tried it one more time and this time it worked!

Last time I hade not yet managed to associate my smartthings location with a geolocation due to another bug.
Anyway, now it works.