SmartThings app freezes when adding a device

I’m trying to add a Q800B soundbar, and the following issues occur:

  1. verification by pressing the “-” button on the soundbar takes a very long time to register in the app
  2. the app then instructs me to enter in network information (network name & password)
  3. when I click to enter in the network information, the app states to “select a network” (see pic), but the network is not found. My home network has worked for months without issue, and it is currently working. The app just can’t “find” it, even though I have an internet connection via the wifi network.

My wifi network is working fine (tried rebooting the router; and 291/214 Mbps up/down via Speedtest). I had previously added this soundbar to my SmartThings account via the app, but now the SmartThings app not longer seems to work.

ios 16.1.1

When I tried to submit this issue via the app, I had to select an “Inquiry type” before I could submit the issue, but there was no inquiry type to select (no options to select from). What a joke…

…so much for “smart” things

Any android devices that you can try?

Thanks @jkp for the suggestion, but no, I don’t have any Android devices