SmartThings and IFTTT not linking DO NOT UNLINK!

I have some virtual switches in my hub that I use to integrate thru IFTTT between ST and my Roomba and Alexa. They stopped working a few days ago. I figured I would just delete the IFTTT “service” from my ST account and re-add it from the IFTTT Service Integration page. Now that I have deleted it from ST, IFTTT errors when I try to add it back in. It seems to initially get thru to ST because it comes back and askes for authorization to read my ST location (AZ Home). The fact that it knows my location is called AZ Home means it got into the ST cloud. When I tell it I Authorize access, it returns in IFTTT that it “Could not connect service”.
Is there a way to create this service link from the ST side in the app? Any other thoughts?

1 Like
1 Like

I have already deleted the IFTTT service link from the Smartthings app. But when I go back to IFTTT to re-link Smartthings, it fails to reconnect. It must be getting initially into my ST account because it asks me for authorization to read/execute my Smartthings location (AZ Home). It would only know my location name from getting logged-in. When I click the Authorize button, it returns with the error “Could not connect service”. That is all it says. I can’t find out any other information.

IFTTT support said a couple of months ago that their original integration was Groovy-based, and they were going to have to rewrite it for the new architecture. :thinking:

Based on what @Paul_Oliver has written below, it sounds like the new integration is working, but you are going to have to link to the new integration from the Ifttt side and you may have to re-create your applets in order to get them to run. There are some other differences as well.

1 Like

OK. Thanks for the guidance.

1 Like

The IFTTT integration has been updated. I switched mine over last week.

1 Like

Not sure you read the whole thing. From the IFTTT side, it will not allow the re-link. It knows that my Smartthings hub location name is “AZ Home”, but when I authorize it to have access to the location, it returns the error “Could not connect to service”. Since I can’t get reconnected to ST (linked), I can’t access any of the SmartThings devices to recreate the applets.

After you got the error message did you go back and check Linked services in the ST. App?

For 1 of my 2 locations I got an error message when I tried to link, but when I went back into Linked Service it was in fact linked and my devices were available in IFTTT.

1 Like

My IFTTT account fails to link as well. I contacted IFTTT support. Here is their reply

January 8, 2023
Hi there,
Thanks for reaching out.
We’re currently investigating an issue that is causing a small number of users to be unable to connect to the SmartThings service.
We’ll update you on this thread as soon as we have some additional information. Thanks for your patience while we investigate this issue!
Daniel from IFTTT


Thanks for that update. I haven’t had any luck getting a hold of IFTTT.

1 Like

I did go back and check, multiple times, and no linked service for IFTTT shows up in my list of services.

1 Like

This is what I got from IFTTT support

There is currently a bug that is affecting some users preventing them from connecting to V2 if they previously connected to the existing Smart Things service so unfortunately it looks like that is causing the issue here.

Dan from IFTTT

The Smartthings service is not even on IFTTT. What am I missing ? This is a fresh new FTTT account …

1 Like

I would just start by creating an IFTTT Applet and chose SmartThings as the trigger and it should take you to linking your account.

@Paul_Oliver That’s what I did. they don’t have the service. It’s gone :slight_smile: Doest it come under a different name than “smartthings” ?

1 Like

I just tried it and had the same problem. I would bet they temporarily shut it down to work on the problem some people are having.


FYI I can confirm IFTTT Smartthings (Legacy) service still working OK.

1 Like

Just tried it again. The SmartThings service doesn’t even show up anymore.


1 Like

If it makes you feel better, it seems they removed the ability to use Smarthings in new applets even for folks that had successfully linked to the IFTTT API Access…

Yeah. I was encouraged when joe.asmar said it was working for him. I have, thru other channels, been able to get the service to appear to link back up to my SmartThings account. But in the IFTTT applets, none of my devices show up for actions.