SmartThings ADT Hub - WiFi Only / No Ethernet port - connectivity issues

I installed and setup the SmartThings ADT Hub a few days ago now. I was able to get all my things migrated over from my plain v2 hub to the ADT hub without issue. The problem with the ADT hub is that there is no Ethernet port and the WiFi radios in the ADT hub do not seem to be that great. I have the hub about 10 feet from my router and it has lost connection to my WiFi network at least once a day. Now it does reconnect within a minute or so but I never had any issues with the V2 hub dropping offline using the Ethernet cable.

Anyone else with the ADT SmartThings hub having this issue?

I hope the radios get tweaked a bit in the coming firmware updates…

I have my ADT Hub mounted on the wall in my Kitchen My Wifi access points are mounted on the ceiling in my loft on the second floor and I have not had any issue. It is about 15 feet down through one floor to get the signal to the hub. Could there be something interfering with your network? The hub connects on the 2.4G network so do you have any Zigbee devices that could be causing a problem? I would check what channel your router is on compared to what the Zigbee is running on and see if there are interfering with each other. You can find more info here:

I built my smart home setup out on 100% Z-Wave plus devices so nothing zigbee to get in the way. I have about 25 other devices on my wifi network at all times and they dont seem to have any issue. Just hoping i didnt get a hub with crap antennas. Also, the ADT hub can connect to 5ghz Wifi… I had mine on it at first but noticed the signal was not as strong so I switched it to 2.4ghz

I have been wanting to get a new router anyways so now might be the time haha. Got my eye on the Asus RT-AC88U…

Yeah I just bought a new house that unfortunately did not have Ethernet in every room. I tried the ASUS routers as I have loved them in the past but could not get high speed wireless. I have gigabit Ethernet so I would like to see at least half that wireless. I have about 50 items on my entire network. I have many cameras and Echos in the house so I decided to go with the Unifi System and separate my IOT items from my Media Streamers and Phones. So far it is working great and I can control some items to only use certain bandwidth to save the rest for streaming. I am just getting into this Home Automation and started with the V2 Hub. I was actually looking at Alarm Systems when I saw the ADT come out. It was expensive to get sensors for all my doors and windows but so far it has been worth it. I also have the Smoke and CO2 detectors and some of the water sensors. I just started the monitoring service so I will see how that goes. Last week my Cleaner set off one of the water sensors mopping the floor. ADT called me to let me know. Nice thing is I was able to tell them that if they see it again during a certain time of the week to ignore it, so that is nice. Good luck with your system.

What model of router do you have?

I have a Linksys AC1900 Max Stream EA7500

I’m connected on 2.4GHz and don’t seem to have any issues. My access point is on the ceiling of my second floor and my ADT panel is in the kitchen at the back of the first floor. I initially had some WiFi issues because the 2.4GHz space is so crowded with all of my neighbor’s networks. I hard coded my access points to the least congested channel and it’s been smooth sailing. Good luck!

Is that the connection statistics from your ADT panel itself? If so, what app are you using to see that? A built-in diagnostic screen on the panel itself would be great being it’s wifi only…

@seeaharrison Your Unifi setup is almost the same as mine. I named mine Smarthings ADT HUB IOT. I really like having the statistics for all my devices. It is nice to be able to login remotely and reconnect devices as needed as well. When my power goes out longer than my battery backups I have a couple of devices I have to force a reconnect

Sorry, the connection stats are from my wireless controller (Ubiquiti Unifi).

Too funny! Yeah, I love my Unifi setup. I’ve got a total of 4 AP-AC-PRO’s across my house, garage and garage apartment. To further segment things I’ve got a VLAN and SSID for IOT, Media, Users and guests. I guess you could call me a bit OCD when it comes to my network. :slight_smile:

Man our system is almost the same. I have the same VLANS and SSIDs. I have an AP-AC-Pro and an AP-AC-HD. I also have 4 of the AP AC Mesh devices to receive signals and transfer them to a wired connection or to boost my IOT network in some areas. I started with the Linksys Velop system but could nto get good wireless speeds. I really like the UniFi system and would recommend it to anybody looking for a good reliable system.

Thanks Kris.

We looked at logs and do see Wi-Fi connection issues. If you’re able and willing, can you try moving the location of the panel or router and see if there is any change? Also, if you have another Wi-Fi router by chance, it’d be nice to rule out it being a router issue.

1 Like

Hi Brad,

I had the panel 10 feet and in direct line of sight of the router in the same room. I have moved it around a bit to see if it made a difference and am not seeing any that I can tell. I currently don’t have another WiFi router. Does this thing require opening any ports on the router to function correctly? I noticed in the logs that the hub looks to be using port 39500 ??

localSrvPortTCP:39500, localSrvPortUDP:0

Also… the disconnects continue to happen today (shown in hubs event list)…

8:35:19 PM (Disconnected) - 8:36:39 PM - Reconnected
2:38:38 PM (Disconnected) - 2:38:45 PM - Reconnected

I have noticed that often If I walk by the panel and turn on the screen the WiFi bars on the screen have an orange exclamation point over it and when I go into settings it says limited connectivity. Just by waking up the panel screen it often goes back to showing full bars on the panel WiFi indicator within seconds… Is the panel going to sleep and in a low power mode lessening the WiFi reception or something? I have tried leaving the panel on my 2.4ghz and 5ghz network and the disconnects happen on both…

Really wish these had Ethernet ports like the plain SmartThings Hubs…

Do you happen to have Google Home devices? I believe those are currently causing issues with some WiFi routers.

@prjct92eh2

I have 2 amazon echo dots on my network and 1 google home mini (I prefer google assistant… wife bought the echo dots…)

EDIT: I just read about the google device issue spamming loads of packets at a time over your network… Google Home devices, Chromecast, and even Android phones are reported to cause the issue.

Disconnects continued through the night… again it only lasts for 30 seconds to a minute each time before it reconnects. I have the following devices on WiFi most of the time and dont see the issues with them…

  • 3 Wemo WiFi Switchs (I plan to ditch these things for zwave switches asap… they suck)
  • Ring Doorbell Pro (connected to the Chime Pro’s WiFi)
  • Ring Chime Pro
  • 4 Amcrest IP Security Cameras
  • 2 Amazon Echo Dots
  • 1 Google Home Mini (Had it unplugged all night so its not the issue)
  • Nest Thermostat
  • 2 Android Phones
  • 2 Android Tablets
  • 1 iPhone
  • 3 Roku boxes

Disconnect 1:
2018-01-16 11:28:20.286 PM EST - disconnected
2018-01-16 11:29:08.189 PM EST - active

Disconnect 2:
2018-01-17 2:20:19.738 AM EST - disconnected
2018-01-17 2:20:32.078 AM EST - active

Disconnect 3:
2018-01-17 8:21:54.252 AM EST - disconnected
2018-01-17 8:22:59.781 AM EST - active

Attached a pic of the panel showing limited connectivity… and within a few seconds of me taking the picture it jumped back to showing full signal on the WiFi indicator on the panel.

ADTHUB

SmartThings staff… you should add a WiFi connection details screen to the panel so we can see how good or bad the signal is on the panel itself (db number) etc…

My disconnect issue has been resolved (at least its been steady for a couple days now) so I thought Id reply with my fix to this issue…

  1. I removed the Ring Chime Pro WiFi extender. This seemed to help as the ADT hub didnt drop connection as often. My ADT Hub sat between my router and where the Chime Pro was plugged in. This however caused my Ring Doorbell to drop connection to my router like crazy… To anyone looking at these Ring products they have crap WiFi antennas or something because in order for them to work properly they need a very very strong connection to your WiFi router… almost like the router has to sit on top of them.

  2. I went ahead and purchased a couple new WiFi Routers for testing. I got the Netgear Nighthawk X4s (7800) and the Asus RT-AC88U.

The Netgear didnt last long in testing as it had worse single range than my existing Linksys EA7500. This caused 1 of my IP Cameras to no longer connect and the Ring Pro Doorbell laughed at it… So back to the store it went… Next I plugged the Asus RT-AC88u in and wow… this router is amazing. Amazing range on the 2.4ghz network as my IP cameras not only connect but are showing better signal strength then they ever have and my Ring Doorbell Pro works perfect without using the Chime extender…

I let the Asus Router run everything for a day and a half and no connection drops to anything including the SmartThings ADT hub.

So in short… if you have connection issues… I recommend looking into a better router. The Asus RT-AC88u is one monster of a router so I recommend you start there if your home is 2000 - 3000 sq ft. If you have a larger home you may want to look into one of the new mesh WiFi solutions.

1 Like

Good morning! Has anyone gathered a fix for the WiFi drop of these hubs? I love the system, yet the disconnect from WiFi is taxing.

1 Like