Smarthings V2 Hub won't connect - flashing blue light

I’m having issues with my Smartthings V2 hub (model STH-ETH-250).

I did a factory reset to the device and it wasn’t connecting to my TP-Link 5 Port Gigabit Ethernet Network Switch. I cycled the modem, the switch, and the hub, but no success.

I then plugged it into my wifi router, which is plugged into the switch. After cycling the model and the hub, it was able to connect and get to it via my smartphone app.

I then moved the hub back to its original location which is next to the switch and had the same connectivity issues. Cycling the model, switch, and hub no impact even after being tried several times.

I tried one poster’s suggestion to force a firmware update but no difference. It’s running v. 000.024.00020.

Any ideas?

Does anything else work when it’s connected to this switch, to the same port, with the same cable?

Hi sidjohn1 - Yes, I’ve added my laptop and the wireless router is plugged into it, as well.

He asked “with the same port and the same cable”. Two things can’t use the same port or the same cable at the same time. Trying to determine if it’s a hardware failure. Sometimes the easiest things tend to be the right ones. You say it is plugged into a switch, do you also have a router? What is managing DHCP on your network? It’s unclear what your network topology is. Can you put together a quick sketch for us? what is connected to what will help.

1 Like

Thanks for your help, I’ll lay out what I have:

XFinity in to cable modem
cable modem to switch
switch to router & smartthings hub

I’ve tried different ports on the switch as well as different cables, using my laptop to confirm that they each worked.

DHCP is all OOTB, I’ve not done anything manual to any of it.

You have things hooked up backwards. Your should first go to the router and then to the switch. Your switch is not going to provide an IP address to any devices. Your DHCP server is in your router, so that should be the first device plugged into the cable modem. Then plug the unmanaged switch into one of the ports on your router.

Thanks, Ryan, that was the issue. I appreciate your help.

1 Like