SmartApp created in IDE, but not showing on app

I created a SmartApp for my Wink Relay using code I found on Github, but I cannot seem to get it to show up in the mobile app. I think it is because it is categorized as “Smartthings Labs”, but I am just guessing. In any case, how do I get it to show up on the app so I can finish setting my Wink Relay up?

Long time coder (1971!), but new to ST (X10 then Wink).

Did you login to IDE at ?

And did you publish the code?

Which app… new or Classic and where did you look?

Logged in to IDE as you noted.

I have published the code, now. Did not realize each step.

New app, not classic.

Hopefully, publishing it will do the trick.

Nothing yet.

where are you looking in the new app?

two places to check:

  1. click on + in the upper right of the dashboard screen, select smartapp and go to the custom section
  2. click on menu (3 bars in the upper left of the screen on dashboard) and select smartapps

if not in either location, you may want to post a link to where you found the code. There is a Wink Relay thread where you can post and someone who uses it or the developer may offer assistance

1 Like

Unfortunately, there is no custom section on my new app, just a list of available apps starting with HomeCare Wizard and ending with SmartSense.

According to the author, I need to follow these steps in the classic app:

  1. Navigate to the Automation tab at the bottom of the screen
  2. Navigate to the SmartApps tab at the top of the screen
  3. Scroll down to the bottom of the screen and select “Add a SmartApp”
  4. Scroll down to bottom of the list and select “My Apps”
  5. Find “Wink Relay” and tap to continue.
  6. Wait for the Device Discovery to complete
  7. After selecting your device from the list, select Save to complete the installation of your device

I have tried this as well. It is in step #4 that I run into an issue. The My Apps section is empty.

in the IDE it says:
Namespace/Name: joshualyon : Wink Relay
Status: Unpublished
Category: SmartThings Labs

When I go to Publishing, it says it was submitted for publishing 7 days ago with no status changes since then.

Tagging @joshua_lyon

It sounds like you may have submitted a publication request rather than saving and publishing the SmartApp.

1 Like

That was it! Thanks! Just not familiar with the interface, as yet.


Hi @joshua_lyon

I followed your steps but couldn’t get the wink relay setup on smartthings (latest version).

What I did: I went to Automation > Add Routine > Discover
From there, tried to do a manual add since ST did not automatically detect the Wink Relay
I added the IP but it doesnt do anything.
Only thing that I can click is the Done button.

Does your code works on the latest version of ST?
Or am I missing a step?


1 Like

I would recommend posting in the Wink Relay thread so other community members who are using this integration could help. As noted in the Wink Relay thread:

I am not personally using Wink Relay devices any more, but the integration remains available for you to use.