Smart Weather Station Tile Device (add using IDE)

Just chiming in here on your values. I have an AEON luminance multi and I have it set for 600 to determine whether it’s too dark outside and the interior lights need to come on. The AEON only seems to go to 0-1000 LUX in full sunlight so 11000 seems like you might be a little close to the sun :smile:

I’m basing it upon the lux values in the smart weather tile device. I simply changed those.

Now I have a bit of a different question concerning ‘Light up the Night Sky’.

How can I simply set a dimmer level instead of turning a device on/off.

Does the luminance thing work on the aeons? Mine forever shows 5-7 lux in the basement when it is lit or dark. Even when I flash a huge torch on it, it shows the same reading. I checked the code and it is of course capped at 1000. But I do need something outdoor for luminance and would really appreciate which sensor to use. Aeons outside are infamous for false motion alerts but are they any good outdoors for luminance? Mine is permanently mounted in the basement and can’t check. Anybody using it outdoors?

I use it to turn the front lights on and off when there is movement and it is dark. Works well. Only the motion is instant, all the other values include lux are not super frequent but good enough for using to determine if it’s dark out.

I mounted mine on a tree that faces the sidewalk from the street side so it can’t see the cars drive by and thus reduced the false positives significantly.

I had all of my stuff that only happened with it is dark tied to the same outside Aeon Multisensor when it went belly up. I have now switched them all to the smart weather tile instead. FWIW they have a 1 year warranty.

1 Like

I’ve converted my 4 instances of custom Smart Night Light to use the lux level as the sunrise and sunset options always failed for me after 24 hours. Using the Weather Tile worked fine but it ignored the before and after offsets. The lux level is never reported correctly in the app interface but behind the scenes in the log it refreshes every 5 minutes just fine. I have my code set to around 700 lux; even if it’s decent outside a couple of our hallways are always a bit too dark. It’s all finally working great so no more turning lights on if it get a bit cloudy or having to turn them off if it’s sunny out. :smile:

BTW if anyone didn’t notice there is a bug in the smart weather station controller which won’t work if you use custom modes instead of all modes (like if you skip night mode). Bug fixed here:

1 Like

I am so lost… No problem creating the Smartweather station tile and, if I use a legit zip code, I get the correct data from that area But… I want to get it from my own station ID. Every one/post says use your station ID within the location field. What location field?? During the creation of the device? In the “Zip Code” field? Do I have to create this location first under “My Locations” Like I said… totally lost on how to get this tile to work with my location.

Ok I found the answer… Station_id is entered in the Zip Code field but I was using the wrong format. For the sake of others, to get data from your personal WX station enter the following into the Zip Code filed
pws:YOUR-WEATHER-UNDERGROUND-STATIONID

No quotes, no brackets

2 Likes

hi all - is there a way to add the Pollen Index from weather underground? http://www.wunderground.com/DisplayPollen.asp?Zipcode=10003 - I suffer from allergies and it would be great to get this forecast as well.

1 Like

From the looks of it, pollen doesn’t look like it can be pulled from the Weather Underground API. Somebody please correct me if I’m wrong, as I would benefit from this addition as well.

https://api.accuweather.com/developers/unitTypes - accuweather has it - couldnt find it wunderground api.

I’m new to all of this. Just installed Smart Tiles - BRILLIANT!

I’m trying to add a Smart Weather tile - I get it all except “network id” What is this, where do I get it?

Sorry if it is a stupid questions, as I wrote, I’m new to this

Thanks

I don’t think it matters as long as it is different then any other device on your hub. I used “weather01” just in case I wanted to add 98 additional weather related devices :smile:

2 Likes

@ersantana3, is there a way to use that API?

My assumption would be yes.

For the past 3 or more hours mine is no longer working.

8:58:26 PM PDT: error java.lang.NullPointerException: Cannot get property ‘id’ on null object @ line 156

Just me? Anyone else? I am using a personal weather station not just the zip code.

Same here. I switched to v2 which seems to still work.

Would you mind sharing a link if you have one to the other version? Thanks.

Looks like I used this one as a custom device type: Smart Weather station tile app

Note that I think this does not work with SmartWeather Station Controller app for scheduled refreshes. I tried to fix that once and ended up reverting back to v1. It’s probably a simple fix. If v1 is permanently dead, I will probably troubleshoot again next week.

@625alex Looks like v2 SmartWeather Station doesn’t show as a selectable weather device in ActiOn dashboard (view and control these devices) either, but my dashoard is still updating weather tile since it was already configured to pull from the v1 device.

I’ll email support about v1 failing today. Suggest others do the same.

This was already covered several times before. I will put it on the site…

If you clone a device type (weather f.e.) it will not be selectable when a particular device type is expected as an input.

If you want your custom weather device type to work with SmartTiles, you have to give it a different name and name space. Then, you have to change SmartTiles code to take device with that new name as input.